summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca4b5e27e2f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-dnsimple
+ pkgdesc = Python2 client for DNSimple domain registration and DNS hosting
+ pkgver = 0.3.6
+ pkgrel = 1
+ url = https://github.com/onlyhavecans/dnsimple-python
+ arch = any
+ license = MIT
+ makedepends = python2-pip
+ depends = python2
+ depends = python2-requests
+ source = https://github.com/onlyhavecans/dnsimple-python/archive/0.3.6.tar.gz
+ md5sums = 2102b56025a75bb7c6dbdfc4d66b59fa
+ sha256sums = 4a8fd76b83fadc282b8fd087af7c4f1f14657f880d71d5f06fe569cbbb0b3b11
+
+pkgname = python2-dnsimple
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e4bfafb6e94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: itsme <mymail@ishere.ru>
+
+
+pkgname=python2-dnsimple
+pkgdesc="Python2 client for DNSimple domain registration and DNS hosting"
+pkgver=0.3.6
+pkgrel=1
+arch=('any')
+url="https://github.com/onlyhavecans/dnsimple-python"
+license=('MIT')
+makedepends=('python2-pip')
+depends=('python2' 'python2-requests')
+source=("https://github.com/onlyhavecans/dnsimple-python/archive/$pkgver.tar.gz")
+md5sums=('2102b56025a75bb7c6dbdfc4d66b59fa')
+sha256sums=('4a8fd76b83fadc282b8fd087af7c4f1f14657f880d71d5f06fe569cbbb0b3b11')
+
+
+package() {
+ cd $srcdir/dnsimple-python-$pkgver
+
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: