summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ec4bd651ffd..f31500497115 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = python-efl-git
pkgdesc = Python bindings for the Enlightenment Foundataion Libraries
- pkgver = 1.7.99.358.641fe47
+ pkgver = 1.8.0.r509.1c1f102
pkgrel = 1
url = http://www.enlightenment.org
arch = i686
arch = x86_64
license = LGPL3
+ license = GPL3
makedepends = git
makedepends = cython
- depends = elementary-git
+ depends = elementary>=1.7.99
depends = python-dbus
- provides = python-efl=1.7.99.358.641fe47
+ provides = python-efl=1.8.0.r509.1c1f102
conflicts = python-efl
source = git://git.enlightenment.org/bindings/python/python-efl.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 8cf781a3316c..cf885e82c642 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=python-efl-git
_pkgname=${pkgname%-*}
-pkgver=1.7.99.358.641fe47
+pkgver=1.8.0.r509.1c1f102
pkgrel=1
pkgdesc="Python bindings for the Enlightenment Foundataion Libraries"
arch=('i686' 'x86_64')
url="http://www.enlightenment.org"
-license=('LGPL3')
-depends=('elementary-git' 'python-dbus')
+license=('LGPL3' 'GPL3')
+depends=('elementary>=1.7.99' 'python-dbus')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
makedepends=('git' 'cython')
@@ -18,7 +18,7 @@ md5sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- echo $(python setup.py -V).$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ echo $(python setup.py -V).r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
build() {
@@ -35,4 +35,5 @@ package() {
# install text files
install -Dm644 AUTHORS "$pkgdir/usr/share/doc/$_pkgname/AUTHORS"
install -Dm644 README "$pkgdir/usr/share/doc/$_pkgname/README"
+ install -Dm644 changes.html "$pkgdir/usr/share/doc/$_pkgname/changes.html"
}