summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--001-setup.py.patch8
-rw-r--r--PKGBUILD42
3 files changed, 34 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 419bc04b9a8b..e54da7ee5fc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = python2-enum34
pkgdesc = Python 3.4 Enum backported
- pkgver = 1.1.9
+ pkgver = 1.1.10
pkgrel = 1
- url = https://bitbucket.org/stoneleaf/enum34
+ url = https://pypi.org/enum34
arch = any
license = BSD
- makedepends = mercurial
makedepends = python2-setuptools
depends = python2
- source = hg+https://bitbucket.org/stoneleaf/enum34#tag=7e3b107656eb
- sha256sums = SKIP
+ source = python2-enum34-1.1.10.tar.gz::https://files.pythonhosted.org/packages/source/e/enum34/enum34-1.1.10.tar.gz
+ source = 001-setup.py.patch
+ sha256sums = cce6a7477ed816bd2542d03d53db9f0db935dd013b70f336a95c73979289f248
+ sha256sums = edee8134057d81b366a002e63a7e1f99536b75436ef54864e06f9925b9c06d74
pkgname = python2-enum34
diff --git a/001-setup.py.patch b/001-setup.py.patch
new file mode 100644
index 000000000000..8a2d17bb5836
--- /dev/null
+++ b/001-setup.py.patch
@@ -0,0 +1,8 @@
+1d0
+< import os
+3,4c2,3
+< import setuptools
+< from distutils.core import setup
+---
+> from setuptools import setup, find_packages
+> # from distutils.core import setup
diff --git a/PKGBUILD b/PKGBUILD
index aae4c527753c..d2120db4b797 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,36 @@
-# Maintainer: Maxime Gauduin <alucryd@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Maxime Gauduin <alucryd@gmail.com>
# Contributor: Schala <schalaalexiazeal@gmail.com>
pkgname=python2-enum34
-pkgver=1.1.9
+pkgver=1.1.10
pkgrel=1
pkgdesc='Python 3.4 Enum backported'
-arch=(any)
-url=https://bitbucket.org/stoneleaf/enum34
-license=(BSD)
-depends=(python2)
-makedepends=(
- mercurial
- python2-setuptools
-)
-source=(hg+https://bitbucket.org/stoneleaf/enum34#tag=7e3b107656eb)
-sha256sums=(SKIP)
-
-pkgver() {
- cd enum34
-
- hg id -t
+arch=('any')
+url='https://pypi.org/enum34'
+license=('BSD')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/e/enum34/enum34-$pkgver.tar.gz"
+ '001-setup.py.patch')
+sha256sums=('cce6a7477ed816bd2542d03d53db9f0db935dd013b70f336a95c73979289f248'
+ 'edee8134057d81b366a002e63a7e1f99536b75436ef54864e06f9925b9c06d74')
+
+prepare() {
+ patch -p1 -d "enum34-$pkgver" setup.py < 001-setup.py.patch
}
build() {
- cd enum34
-
+ cd "enum34-$pkgver"
python2 setup.py build
}
package() {
- cd enum34
-
+ export PYTHONHASHSEED=0
+ cd "enum34-$pkgver"
python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm 644 enum/LICENSE -t "${pkgdir}"/usr/share/licenses/python2-enum34/
+ install -Dm644 enum/LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 enum/README -t "$pkgdir/usr/share/doc/$pkgname/"
}
# vim: ts=2 sw=2 et: