summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 997bcddbb10b..2f442861652c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python2-evdev
pkgdesc = Python2 bindings for the Linux input subsystem
pkgver = 1.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://python-evdev.readthedocs.io/en/latest/
arch = x86_64
license = BSD
@@ -9,7 +9,9 @@ pkgbase = python2-evdev
makedepends = git
depends = python2-pbr
source = git+https://github.com/gvalkov/python-evdev#tag=v1.3.0
+ source = https://patch-diff.githubusercontent.com/raw/gvalkov/python-evdev/pull/119.patch
sha256sums = SKIP
+ sha256sums = aedf0f1623572f448ea049d7c5ee60c7fcf5334bc619a4e2a2b1ecba3def6627
pkgname = python2-evdev
diff --git a/PKGBUILD b/PKGBUILD
index 555b54833224..7c2c615b2732 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,28 @@
pkgname=python2-evdev
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python2 bindings for the Linux input subsystem"
arch=(x86_64)
url="https://python-evdev.readthedocs.io/en/latest/"
license=(BSD)
depends=(python2-pbr)
makedepends=(python2 git)
-source=("git+https://github.com/gvalkov/python-evdev#tag=v$pkgver")
-sha256sums=('SKIP')
+source=("git+https://github.com/gvalkov/python-evdev#tag=v$pkgver"
+ "https://patch-diff.githubusercontent.com/raw/gvalkov/python-evdev/pull/119.patch")
+sha256sums=('SKIP'
+ 'aedf0f1623572f448ea049d7c5ee60c7fcf5334bc619a4e2a2b1ecba3def6627')
pkgver() {
cd python-evdev
git describe --tags | sed 's/^v//;s/-/+/g'
}
+prepare() {
+ cd python-evdev
+ git apply ../119.patch
+}
+
build() {
cd python-evdev
python2 setup.py build