summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--COPYING50
-rw-r--r--PKGBUILD28
3 files changed, 77 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9280187ed21a..6ee700a6545b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = python2-frida
- pkgdesc = Inject JavaScript to explore native apps on Windows, Mac, Linux, iOS and Android. Python 2 version from PyPi
- pkgver = 5.0.10
+ pkgdesc = Inject JavaScript to explore native apps on Windows, Mac, Linux, iOS and Android. Python 2 version from PyPi.
+ pkgver = 12.2.19
pkgrel = 1
url = http://www.frida.re
- arch = any
+ arch = i686
+ arch = x86_64
license = wxWindows Library License, Version 3.1
depends = python2
- depends = python2-pygments>=2.0.2
- depends = python2-prompt_toolkit>=0.38
- depends = python2-colorama>=0.2.7
- source = https://pypi.python.org/packages/source/f/frida/frida-5.0.10.zip
- md5sums = d33c5cc14a4dd624ec0a7fa4dedba8ee
+ depends = python2-pygments
+ depends = python2-prompt_toolkit=1.0.15
+ depends = python2-colorama
+ conflicts = python-frida
+ source = https://files.pythonhosted.org/packages/1b/fa/344500d06d3bf5b70c7252623440ae73cf064965b1d38c559af8521e868c/frida-12.2.19.tar.gz
+ source = COPYING
+ sha256sums = ba15e38367712756af11bdce28be60d8ed39747966f58dc3656dffd44befbe49
+ sha256sums = 5ea1544b51a28bc823b03159190d4108f9fb4f4ef912389f5137c6d295e175b2
pkgname = python2-frida
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..b01d49c670e5
--- /dev/null
+++ b/COPYING
@@ -0,0 +1,50 @@
+ wxWindows Library Licence, Version 3.1
+ ======================================
+
+Copyright (c) 1998-2005 Julian Smart, Robert Roebling et al
+
+Everyone is permitted to copy and distribute verbatim copies
+of this licence document, but changing it is not allowed.
+
+ WXWINDOWS LIBRARY LICENCE
+ TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
+
+This library is free software; you can redistribute it and/or modify it
+under the terms of the GNU Library General Public Licence as published by
+the Free Software Foundation; either version 2 of the Licence, or (at your
+option) any later version.
+
+This library is distributed in the hope that it will be useful, but WITHOUT
+ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+FITNESS FOR A PARTICULAR PURPOSE. See the GNU Library General Public
+Licence for more details.
+
+You should have received a copy of the GNU Library General Public Licence
+along with this software, usually in a file named COPYING.LIB. If not,
+write to the Free Software Foundation, Inc., 51 Franklin Street, Fifth
+Floor, Boston, MA 02110-1301 USA.
+
+EXCEPTION NOTICE
+
+1. As a special exception, the copyright holders of this library give
+permission for additional uses of the text contained in this release of the
+library as licenced under the wxWindows Library Licence, applying either
+version 3.1 of the Licence, or (at your option) any later version of the
+Licence as published by the copyright holders of version 3.1 of the Licence
+document.
+
+2. The exception is that you may use, copy, link, modify and distribute
+under your own terms, binary object code versions of works based on the
+Library.
+
+3. If you copy code from files distributed under the terms of the GNU
+General Public Licence or the GNU Library General Public Licence into a
+copy of this library, as this licence permits, the exception does not apply
+to the code that you add in this way. To avoid misleading anyone as to the
+status of such modified files, you must delete this exception notice from
+such code and/or adjust the licensing conditions notice accordingly.
+
+4. If you write modifications of your own for this library, it is your
+choice whether to permit this exception to apply to your modifications. If
+you do not wish that, you must delete the exception notice from such code
+and/or adjust the licensing conditions notice accordingly.
diff --git a/PKGBUILD b/PKGBUILD
index 05ea7524544b..ead4cf9bb64f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,30 @@
+# Current Maintainer: algebro <algebro at tuta dot io>
+# Previous Maintainer: visad
+
_pkgname=frida
pkgname=python2-$_pkgname
-pkgver=5.0.10
+pkgver=12.2.19
pkgrel=1
-pkgdesc="Inject JavaScript to explore native apps on Windows, Mac, Linux, iOS and Android. Python 2 version from PyPi"
-arch=('any')
+pkgdesc="Inject JavaScript to explore native apps on Windows, Mac, Linux, iOS and Android. Python 2 version from PyPi."
+arch=('i686' 'x86_64')
url="http://www.frida.re"
license=('wxWindows Library License, Version 3.1')
-depends=('python2' 'python2-pygments>=2.0.2' 'python2-prompt_toolkit>=0.38' 'python2-colorama>=0.2.7')
-source=("https://pypi.python.org/packages/source/f/frida/frida-${pkgver}.zip")
-md5sums=('d33c5cc14a4dd624ec0a7fa4dedba8ee')
+depends=('python2' 'python2-pygments' 'python2-prompt_toolkit=1.0.15' 'python2-colorama')
+source=("https://files.pythonhosted.org/packages/1b/fa/344500d06d3bf5b70c7252623440ae73cf064965b1d38c559af8521e868c/frida-${pkgver}.tar.gz"
+ "COPYING")
+sha256sums=('ba15e38367712756af11bdce28be60d8ed39747966f58dc3656dffd44befbe49'
+ '5ea1544b51a28bc823b03159190d4108f9fb4f4ef912389f5137c6d295e175b2')
+conflicts=("python-${_pkgname}")
build() {
cd "$srcdir/$_pkgname-$pkgver"
-
- # those names have been changed in prompt_toolkit 0.54
- if [[ $(pacman -Qi --color=never python2-prompt_toolkit | sed -n 2p | cut -d ":" -f2 | tr -d '[[:space:]]' | xargs -I ver vercmp ver 0.54) -ge 0 ]]; then
- sed -i 's/create_default_application/create_prompt_application/g' frida/repl.py
- sed -i 's/create_default_output/create_output/g' frida/repl.py
- fi
-
python2 setup.py build
}
package() {
cd "$srcdir/$_pkgname-$pkgver"
python2 setup.py install --root=$pkgdir --optimize=1 --skip-build
+ cd "$srcdir"
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ install -m 644 "COPYING" "$pkgdir/usr/share/licenses/$pkgname/"
}