summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5333b8b05dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-gmpy
+ pkgdesc = Python extension that wraps GMP to provide fast multiprecision arithmetic. Last of the 1.x series, see gmpy2 for new developments.
+ pkgver = 1.17
+ pkgrel = 1
+ url = http://code.google.com/p/gmpy/
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ depends = python2
+ depends = gmp
+ options = !emptydirs
+ source = http://gmpy.googlecode.com/files/gmpy-1.17.zip
+ md5sums = 2bf419076b06e107167e219f60ac6d27
+
+pkgname = python2-gmpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6bed2c4eae3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: S.Leduc <sebastien@sleduc.fr>
+# Contributor: Adam "falcon7" Chidlow <falcon7 _AT_ standardnerd.org>
+
+pkgname=python2-gmpy
+pkgver=1.17
+pkgrel=1
+pkgdesc="Python extension that wraps GMP to provide fast multiprecision arithmetic. Last of the 1.x series, see gmpy2 for new developments."
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/gmpy/"
+license=('LGPL2.1')
+depends=('python2' 'gmp')
+options=(!emptydirs)
+source=("http://gmpy.googlecode.com/files/gmpy-${pkgver}.zip")
+md5sums=('2bf419076b06e107167e219f60ac6d27')
+
+package() {
+ cd "$srcdir/gmpy-$pkgver"
+ python2 setup.py install --root=$pkgdir/ --optimize=1
+
+ install -d -m 755 $pkgdir/usr/share/doc/$pkgname
+ install -m 644 -t $pkgdir/usr/share/doc/$pkgname doc/*
+}
+
+# vim:set ts=2 sw=2 et: