summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
3 files changed, 44 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..ad8b648bcde5
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-guppy
+ pkgdesc = Python memory profiler and debugger
+ pkgver = 0.1.10
+ pkgrel = 2
+ url = http://guppy-pe.sourceforge.net
+ arch = any
+ license = GPL
+ depends = python2
+ source = http://pypi.python.org/packages/source/g/guppy/guppy-0.1.10.tar.gz
+ md5sums = 08942f467160a3559f76ea622256d699
+
+pkgname = python2-guppy
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad8b648bcde5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-guppy
+ pkgdesc = Python memory profiler and debugger
+ pkgver = 0.1.10
+ pkgrel = 2
+ url = http://guppy-pe.sourceforge.net
+ arch = any
+ license = GPL
+ depends = python2
+ source = http://pypi.python.org/packages/source/g/guppy/guppy-0.1.10.tar.gz
+ md5sums = 08942f467160a3559f76ea622256d699
+
+pkgname = python2-guppy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0969c5de792a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Sebastien Leduc <sebastien@sleduc.fr>
+# Contributor: Hervé Cauwelier <herve/oursours/net>
+pkgname=python2-guppy
+_realname=guppy
+pkgver=0.1.10
+pkgrel=2
+pkgdesc="Python memory profiler and debugger"
+arch=('any')
+url="http://guppy-pe.sourceforge.net"
+license=('GPL')
+depends=('python2')
+source=( "http://pypi.python.org/packages/source/g/guppy/$_realname-$pkgver.tar.gz")
+md5sums=('08942f467160a3559f76ea622256d699')
+
+package() {
+ cd "$srcdir"/$_realname-$pkgver
+ python2 ./setup.py install --root="$pkgdir"
+}