summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD27
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e09e3e3e09fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-houdinipy
+ pkgdesc = A Python binding for Houdini that provides (un)escaping functions for HTML, URLs/URIs and Javascript.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = http://python-houdini.61924.nl/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = python2
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/h/houdini.py/houdini.py-0.1.0.tar.gz
+ source = LICENSE
+ sha256sums = cabd10734a859c34c3707ecb99b93cb78547a9128cbfabbe3f4d5628e822f666
+ sha256sums = 0fed45cfa40d1ceed4bf0173f11af10e962d2647a4beb7c0e8250a30720a1890
+
+pkgname = python2-houdinipy
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..263ff2d897a9
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+Copyright (C) 2011 by Frank Smit <frank@61924.nl>
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cba7426e99bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: mutantmonkey <aur@mutantmonkey.in>
+pkgname=python2-houdinipy
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A Python binding for Houdini that provides (un)escaping functions for HTML, URLs/URIs and Javascript."
+arch=('i686' 'x86_64')
+url="http://python-houdini.61924.nl/"
+license=('MIT')
+depends=('python2')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/h/houdini.py/houdini.py-${pkgver}.tar.gz"
+ 'LICENSE')
+sha256sums=('cabd10734a859c34c3707ecb99b93cb78547a9128cbfabbe3f4d5628e822f666'
+ '0fed45cfa40d1ceed4bf0173f11af10e962d2647a4beb7c0e8250a30720a1890')
+
+package() {
+ cd "$srcdir/houdini.py-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/houdini.py-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: