summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69b56f853ec9..47b3614fef18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Tue May 3 17:12:41 UTC 2016
pkgbase = python2-ifcopenshell-git
pkgdesc = Open source IFC library and geometry engine. Provides only wrapper for python2. GIT version.
- pkgver = 0.r355.gc6a265a
+ pkgver = 0.r550.gfefa8a0
pkgrel = 1
url = http://ifcopenshell.org/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 6aeec28f7c7c..84704af5c57e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: mickele <mimocciola[at]yahoo[dot]com>
pkgname=python2-ifcopenshell-git
-pkgver=0.r355.gc6a265a
+pkgver=0.r550.gfefa8a0
pkgrel=1
pkgdesc="Open source IFC library and geometry engine. Provides only wrapper for python2. GIT version."
url="http://ifcopenshell.org/"
@@ -35,6 +35,10 @@ prepare(){
sed -e 's|\t#include "../ifcgeom/IfcGeom.h"|\t// #include "../ifcgeom/IfcGeom.h"|' -i src/ifcwrap/IfcPython.i
sed -e 's|\t#include "../ifcgeom/IfcGeomIterator.h"|\t#include "../ifcgeom/IfcGeomIterator.h"\n\t#include "../ifcgeom/IfcGeom.h"|' -i src/ifcwrap/IfcPython.i
+
+ sed -e "s|FIND_PACKAGE(Boost REQUIRED COMPONENTS system program_options regex thread date_time)|FIND_PACKAGE(Boost REQUIRED COMPONENTS system program_options regex thread date_time)\nADD_DEFINITIONS(-DBOOST_OPTIONAL_USE_OLD_DEFINITION_OF_NONE)|" -i cmake/CMakeLists.txt
+
+ sed -e "s|boost::shared_ptr<Representation::Triangulation<P>>|boost::shared_ptr<Representation::Triangulation<P> >|" -i src/ifcgeom/IfcGeomElement.h
}
build() {
@@ -45,6 +49,7 @@ build() {
local _pythonver=$(python2 --version 2>&1)
cmake ../cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_CXX_STANDARD=11 \
-DOCC_INCLUDE_DIR=/opt/opencascade/inc \
-DOCC_LIBRARY_DIR=/opt/opencascade/lib \
-DOPENCOLLADA_INCLUDE_DIR=/usr/include/opencollada \