summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--ftheaders.patch16
3 files changed, 33 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3fc92d2eae9d..7c98056772d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Sat Dec 19 10:28:47 UTC 2015
pkgbase = python2-imaging
pkgdesc = PIL. Provides image processing capabilities for python
pkgver = 1.1.7
- pkgrel = 12
+ pkgrel = 14
url = http://www.pythonware.com/products/pil/index.htm
arch = i686
arch = x86_64
@@ -22,8 +20,10 @@ pkgbase = python2-imaging
provides = pil=1.1.7
conflicts = pil
replaces = pil
- source = http://effbot.org/downloads/Imaging-1.1.7.tar.gz
+ source = https://src.fedoraproject.org/repo/pkgs/python-imaging/Imaging-1.1.7.tar.gz/fc14a54e1ce02a0225be8854bfba478e/Imaging-1.1.7.tar.gz
+ source = ftheaders.patch
md5sums = fc14a54e1ce02a0225be8854bfba478e
+ md5sums = 8e38bfc967145c5467b57f40ceed63e7
pkgname = python2-imaging
diff --git a/PKGBUILD b/PKGBUILD
index c652d5359297..60f9c451a8b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer : Yen Chi Hsuan <yan12125@gmail.com>
+# Maintainer: Yen Chi Hsuan <miha.frangez at gmail dot com>
+# Contributor: Yen Chi Hsuan <yan12125@gmail.com>
# Contributor: jyantis <yantis@yantis.net>
# Contributor: Rob McCathie <archaur at rmcc dot com dot au>
# Contributor: Yanus Poluektovich <ypoluektovich@gmail.com>
@@ -9,7 +10,7 @@
pkgname=python2-imaging
pkgver=1.1.7
-pkgrel=12
+pkgrel=14
pkgdesc="PIL. Provides image processing capabilities for python"
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'armv6l')
url="http://www.pythonware.com/products/pil/index.htm"
@@ -21,8 +22,16 @@ optdepends=('tk: for the ImageTK module'
provides=("pil=${pkgver}")
conflicts=('pil')
replaces=('pil')
-source=(http://effbot.org/downloads/Imaging-${pkgver}.tar.gz)
-md5sums=('fc14a54e1ce02a0225be8854bfba478e')
+source=(https://src.fedoraproject.org/repo/pkgs/python-imaging/Imaging-${pkgver}.tar.gz/fc14a54e1ce02a0225be8854bfba478e/Imaging-${pkgver}.tar.gz
+ ftheaders.patch)
+md5sums=('fc14a54e1ce02a0225be8854bfba478e'
+ '8e38bfc967145c5467b57f40ceed63e7')
+
+prepare() {
+ cd "${srcdir}/Imaging-${pkgver}"
+
+ patch -F 0 -N -p1 -i ../ftheaders.patch
+}
build() {
cd "${srcdir}/Imaging-${pkgver}"
diff --git a/ftheaders.patch b/ftheaders.patch
new file mode 100644
index 000000000000..adc050a46704
--- /dev/null
+++ b/ftheaders.patch
@@ -0,0 +1,16 @@
+--- Imaging-1.1.7/_imagingft.c.orig 2016-02-17 22:51:22.173689472 +0800
++++ Imaging-1.1.7/_imagingft.c 2016-02-17 22:53:45.743683886 +0800
+@@ -70,7 +70,13 @@
+ const char* message;
+ } ft_errors[] =
+
++#if defined(USE_FREETYPE_2_1)
++/* freetype 2.1 and newer */
++#include FT_ERRORS_H
++#else
++/* freetype 2.0 */
+ #include <freetype/fterrors.h>
++#endif
+
+ /* -------------------------------------------------------------------- */
+ /* font objects */