summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e22efe38bdbb..7c0f9f874c30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
-pkgbase = python-jsonstreams
+pkgbase = python2-jsonstreams
pkgdesc = A Python module for writing JSON as a stream
pkgver = 0.4.1
pkgrel = 1
url = https://github.com/dcbaker/jsonstreams
arch = any
license = MIT
- makedepends = python-setuptools
- optdepends = python-simplejson
+ makedepends = python2-setuptools
+ depends = python2-enum34
+ optdepends = python2-simplejson
options = !emptydirs
source = https://pypi.python.org/packages/09/9b/21a1d63160166e58a4b2e24f068c1bf9bfb3610f389d39cd5e96910b4f47/jsonstreams-0.4.1.tar.gz
source = https://pypi.python.org/packages/09/9b/21a1d63160166e58a4b2e24f068c1bf9bfb3610f389d39cd5e96910b4f47/jsonstreams-0.4.1.tar.gz.asc
@@ -16,5 +17,5 @@ pkgbase = python-jsonstreams
sha256sums = SKIP
sha256sums = 8b1cc8af45b502fd5bfce434721cb0d9a833298f05fe983ebc6c7f36d06fab59
-pkgname = python-jsonstreams
+pkgname = python2-jsonstreams
diff --git a/PKGBUILD b/PKGBUILD
index f051ab40daf7..52efce3587ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Dylan Baker <dylan@pnwbakers.com>
_name=jsonstreams
-pkgname=python-${_name}
+pkgname=python2-${_name}
pkgver=0.4.1
pkgrel=1
pkgdesc="A Python module for writing JSON as a stream"
@@ -8,8 +8,9 @@ arch=('any')
url="https://github.com/dcbaker/jsonstreams"
license=('MIT')
depends=()
-makedepends=('python-setuptools')
-optdepends=('python-simplejson')
+depends=('python2-enum34')
+optdepends=('python2-simplejson')
+makedepends=('python2-setuptools')
options=(!emptydirs)
source=('https://pypi.python.org/packages/09/9b/21a1d63160166e58a4b2e24f068c1bf9bfb3610f389d39cd5e96910b4f47/jsonstreams-0.4.1.tar.gz'
'https://pypi.python.org/packages/09/9b/21a1d63160166e58a4b2e24f068c1bf9bfb3610f389d39cd5e96910b4f47/jsonstreams-0.4.1.tar.gz.asc'
@@ -25,7 +26,7 @@ prepare() {
package() {
cd "$srcdir/${_name}-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python2 setup.py install --root="$pkgdir/" --optimize=1
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}