summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD8
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 389b520444aa..37cfd4a26df6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
-pkgbase = python-jsonstreams
+pkgbase = python2-jsonstreams
pkgdesc = A Python module for writing JSON as a stream
- pkgver = 0.3.1
+ pkgver = 0.3.2
pkgrel = 1
url = https://github.com/dcbaker/jsonstreams
arch = any
license = MIT
- depends = python
- optdepends = python-simplejson
+ makedepends = python2-setuptools
+ optdepends = python2-simplejson
options = !emptydirs
- source = https://pypi.python.org/packages/b6/4e/fc68910cc9b72bca0f9ee8d8cdc7d3ef55c03ab62b2dfb9338d74639f11c/jsonstreams-0.3.1.tar.gz
- source = https://pypi.python.org/packages/b6/4e/fc68910cc9b72bca0f9ee8d8cdc7d3ef55c03ab62b2dfb9338d74639f11c/jsonstreams-0.3.1.tar.gz.asc
+ source = https://pypi.python.org/packages/28/57/d70adaa037212b48cb06c58055fafae94e482fed50f7ba5addc053ee9588/jsonstreams-0.3.2.tar.gz
+ source = https://pypi.python.org/packages/28/57/d70adaa037212b48cb06c58055fafae94e482fed50f7ba5addc053ee9588/jsonstreams-0.3.2.tar.gz.asc
source = https://raw.githubusercontent.com/dcbaker/jsonstreams/master/LICENSE
validpgpkeys = 5303CCAA8FFEE5A1472F3538089E1696140688EF
- sha256sums = 41a7f787692fc170aff94702376cf972d1ed9678638c1b8340cb9ac15d372ed7
+ sha256sums = 7d7802cc23509d1d129d640e591651f979defc74da69cb8577c6dbcf26b5a5e5
sha256sums = SKIP
sha256sums = 8b1cc8af45b502fd5bfce434721cb0d9a833298f05fe983ebc6c7f36d06fab59
-pkgname = python-jsonstreams
+pkgname = python2-jsonstreams
diff --git a/PKGBUILD b/PKGBUILD
index fa4a360e16b4..97f1526b1a5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Dylan Baker <dylan@pnwbakers.com>
_name=jsonstreams
-pkgname=python-${_name}
+pkgname=python2-${_name}
pkgver=0.3.2
pkgrel=1
pkgdesc="A Python module for writing JSON as a stream"
@@ -8,8 +8,8 @@ arch=('any')
url="https://github.com/dcbaker/jsonstreams"
license=('MIT')
depends=()
-makedepends=('python-setuptools')
-optdepends=('python-simplejson')
+optdepends=('python2-simplejson')
+makedepends=('python2-setuptools')
options=(!emptydirs)
source=('https://pypi.python.org/packages/28/57/d70adaa037212b48cb06c58055fafae94e482fed50f7ba5addc053ee9588/jsonstreams-0.3.2.tar.gz'
'https://pypi.python.org/packages/28/57/d70adaa037212b48cb06c58055fafae94e482fed50f7ba5addc053ee9588/jsonstreams-0.3.2.tar.gz.asc'
@@ -25,7 +25,7 @@ prepare() {
package() {
cd "$srcdir/${_name}-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python2 setup.py install --root="$pkgdir/" --optimize=1
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}