summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54be7b4cbcf3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-langid
+ pkgdesc = A standalone Language Identification (LangID) tool
+ pkgver = 1.1.6
+ pkgrel = 1
+ url = https://github.com/saffsd/langid.py
+ arch = any
+ license = BSD
+ depends = python2
+ depends = python2-numpy
+ source = https://pypi.python.org/packages/ea/4c/0fb7d900d3b0b9c8703be316fbddffecdab23c64e1b46c7a83561d78bd43/langid-1.1.6.tar.gz
+ sha256sums = 044bcae1912dab85c33d8e98f2811b8f4ff1213e5e9a9e9510137b84da2cb293
+
+pkgname = python2-langid
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..243b73a498b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Gabriel Magno <gabrielmagno1@gmail.com>
+
+_pkgname=langid
+pkgname=python2-langid
+pkgver=1.1.6
+pkgrel=1
+pkgdesc="A standalone Language Identification (LangID) tool"
+arch=('any')
+url="https://github.com/saffsd/langid.py"
+license=('BSD')
+depends=('python2' 'python2-numpy')
+source=("https://pypi.python.org/packages/ea/4c/0fb7d900d3b0b9c8703be316fbddffecdab23c64e1b46c7a83561d78bd43/$_pkgname-$pkgver.tar.gz")
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+sha256sums=('044bcae1912dab85c33d8e98f2811b8f4ff1213e5e9a9e9510137b84da2cb293')
+
+# vim:set ts=2 sw=2 et: