summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e3f8db42098
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Thu May 26 18:54:17 UTC 2016
+pkgbase = python2-libusb1
+ pkgdesc = Pure python wrapper for libusb
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://github.com/vpelletier/python2-libusb1
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = python2-distutils-extra
+ makedepends = python2-setuptools
+ depends = python2
+ depends = libusbx
+ conflicts = python2-libusb1-git
+ source = git+https://github.com/vpelletier/python-libusb1.git
+ md5sums = SKIP
+
+pkgname = python2-libusb1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7a600755141
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Carsten Feuls <archlinux@carstenfeuls.de>
+
+pkgname=python2-libusb1
+_pkgname=libusb1
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="Pure python wrapper for libusb"
+arch=('any')
+url="https://github.com/vpelletier/${pkgname}"
+license=('GPL2')
+makedepends=('git' 'python2-distutils-extra' 'python2-setuptools')
+depends=('python2' 'libusbx')
+optdepends=()
+conflicts=("${pkgname}-git")
+source=("git+https://github.com/vpelletier/python-libusb1.git")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/python-libusb1"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/python-libusb1"
+ python2 setup.py install --root="${pkgdir}" \
+ --prefix="/usr" \
+ --compile -O1
+}