summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD25
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9aab375e792c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 4.2.1
+# Mon Apr 6 16:03:10 UTC 2015
+pkgbase = python2-linux-gpib
+ pkgdesc = A support package for GPIB (IEEE 488) hardware - Python 2 bindings
+ pkgver = 3.2.21
+ pkgrel = 2
+ url = http://linux-gpib.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = linux-gpib
+ depends = python2
+ source = http://downloads.sourceforge.net/project/linux-gpib/linux-gpib%20for%203.x.x%20and%202.6.x%20kernels/3.2.21/linux-gpib-3.2.21.tar.gz
+ md5sums = 91e15d1a30c6e3fd79fc6762e8c1120e
+
+pkgname = python2-linux-gpib
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..995bbc514134
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+pkg/*
+src/*
+*.tar.gz
+*.tar.xz
+*.tar.bz2
+*.zip
+*.swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5be37a13e1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=('python2-linux-gpib')
+_pkgname=('linux-gpib')
+pkgver=3.2.21
+pkgrel=2
+pkgdesc='A support package for GPIB (IEEE 488) hardware - Python 2 bindings'
+arch=('i686' 'x86_64')
+url='http://linux-gpib.sourceforge.net/'
+license=('GPL')
+depends=('linux-gpib' 'python2')
+source=("http://downloads.sourceforge.net/project/${_pkgname}/${_pkgname}%20for%203.x.x%20and%202.6.x%20kernels/${pkgver}/${_pkgname}-${pkgver}.tar.gz")
+
+md5sums=('91e15d1a30c6e3fd79fc6762e8c1120e')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}/language/python/"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}/language/python"
+ python2 setup.py install --prefix=/usr --root=${pkgdir}
+
+}
+
+# vim:ts=4:et:sw=4