summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..693e82ae0abd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun May 8 20:59:51 UTC 2016
+pkgbase = python2-matplotlib2tikz
+ pkgdesc = Convert matplotlib figures into TikZ/PGFPlots
+ pkgver = 0.5.7
+ pkgrel = 1
+ url = https://github.com/nschloe/matplotlib2tikz
+ arch = any
+ license = MIT
+ makedepends = python2
+ depends = python2
+ depends = python2-numpy
+ depends = python2-matplotlib>=1.4.0
+ depends = python2-pillow
+ source = https://github.com/nschloe/matplotlib2tikz/archive/v0.5.7.tar.gz
+ sha256sums = b5378b947c1d7ce3eb30c3bf4a5e4a9034a623d3d4d38b6e10b43c3cd0f083d7
+
+pkgname = python2-matplotlib2tikz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d27de52a99d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Kashif <kashifb+aur@gmail.com>
+pkgname=python2-matplotlib2tikz
+pkgver=0.5.7
+pkgrel=1
+pkgdesc="Convert matplotlib figures into TikZ/PGFPlots"
+url="https://github.com/nschloe/matplotlib2tikz"
+depends=('python2' 'python2-numpy' 'python2-matplotlib>=1.4.0' 'python2-pillow')
+makedepends=('python2')
+license=('MIT')
+arch=('any')
+source=("https://github.com/nschloe/matplotlib2tikz/archive/v${pkgver}.tar.gz")
+sha256sums=('b5378b947c1d7ce3eb30c3bf4a5e4a9034a623d3d4d38b6e10b43c3cd0f083d7')
+
+build() {
+ cd "${srcdir}/matplotlib2tikz-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/matplotlib2tikz-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}