summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4cd76fdbf1f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-matplotlib2tikz-git
+ pkgdesc = Convert matplotlib figures into TikZ/PGFPlots
+ pkgver = 0.6.11.r9.g86991b3
+ pkgrel = 1
+ url = https://github.com/nschloe/matplotlib2tikz
+ arch = any
+ license = MIT
+ makedepends = python2
+ depends = python2
+ depends = python2-numpy
+ depends = python2-matplotlib>=1.4.0
+ depends = python2-pillow
+ provides = python2-matplotlib2tikz
+ conflicts = python2-matplotlib2tikz
+ source = git+https://github.com/nschloe/matplotlib2tikz.git
+ md5sums = SKIP
+
+pkgname = python2-matplotlib2tikz-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27d8d12510a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: sasvari <sasvari@fastmail.com>
+pkgname=python2-matplotlib2tikz-git
+pkgver=0.6.11.r9.g86991b3
+pkgrel=1
+pkgdesc="Convert matplotlib figures into TikZ/PGFPlots"
+url="https://github.com/nschloe/matplotlib2tikz"
+depends=('python2' 'python2-numpy' 'python2-matplotlib>=1.4.0' 'python2-pillow')
+makedepends=('python2')
+provides=('python2-matplotlib2tikz')
+conflicts=('python2-matplotlib2tikz')
+license=('MIT')
+arch=('any')
+source=("git+https://github.com/nschloe/matplotlib2tikz.git")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/matplotlib2tikz"
+ python2 setup.py build
+}
+
+pkgver() {
+ cd "$srcdir/matplotlib2tikz"
+ git describe --tags | sed 's/^v//; s/-/.r/; s/-/./'
+}
+
+#package() {
+# cd "${srcdir}/matplotlib2tikz-${pkgver}"
+# python2 setup.py install --root="${pkgdir}" --optimize=1
+# install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+#}
+package() {
+ cd "$srcdir/matplotlib2tikz"
+ python setup.py install --root="$pkgdir/" --prefix="/usr"
+}