summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55a1b56d5ab0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-mingus
+ pkgdesc = a package for Python used by programmers, musicians, composers and researchers to make and investigate music.
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = https://github.com/bspaans/python-mingus
+ arch = any
+ license = GPL
+ depends = python2
+ optdepends = lilypond
+ optdepends = fluidsynth
+ options = !emptydirs
+ source = https://github.com/bspaans/python-mingus/archive/0.5.1.tar.gz
+ md5sums = 95aff384c90f8b06345b67dc922740c9
+
+pkgname = python2-mingus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f2d152dc4a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mark Coolen <mark dot coolen at gmail dot com>
+pkgname=python2-mingus
+_pkgname=python-mingus
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="a package for Python used by programmers, musicians, composers and researchers
+to make and investigate music."
+arch=('any')
+url="https://github.com/bspaans/python-mingus"
+license=('GPL')
+depends=('python2')
+optdepends=('lilypond' 'fluidsynth')
+source=("https://github.com/bspaans/python-mingus/archive/${pkgver}.tar.gz")
+options=(!emptydirs)
+md5sums=('95aff384c90f8b06345b67dc922740c9')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ cd "$pkgdir/usr"
+ mv mingus_examples lib/python2.7/site-packages/mingus/examples
+}