summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE37
-rw-r--r--PKGBUILD22
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87b7c258df19
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-newrelic
+ pkgdesc = Python agent for the New Relic web application performance monitoring service.
+ pkgver = 2.52.0.40
+ pkgrel = 1
+ url = http://newrelic.com/docs/python/new-relic-for-python
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = python2-setuptools
+ depends = python2
+ source = http://download.newrelic.com/python_agent/release/newrelic-2.52.0.40.tar.gz
+ source = LICENSE
+ sha512sums = 0cd6c54b45fb0d33c3eee325666256ab2ad3f04815ac80bf8f9974cf934ab708f29ed58b7d71f7866e4dcf8295ff3f562e47ddaccdc6293f639db7b28585ae24
+ sha512sums = a9d8e4cf71c6bbb372aeb62fca5ced760ea00f406938d28cff57b9d9097abff1580649585f760e0131d59ff764aa2f5249b0ef19233981800211ede66633402b
+
+pkgname = python2-newrelic
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..7b89635af8f5
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,37 @@
+Copyright (c) 2010-2011 New Relic, Inc. All rights reserved.
+
+Certain inventions disclosed in this file may be claimed within
+patents owned or patent applications filed by New Relic, Inc. or third
+parties.
+
+Subject to the terms of this notice, New Relic grants you a
+nonexclusive, nontransferable license, without the right to
+sublicense, to (a) install and execute one copy of these files on any
+number of workstations owned or controlled by you and (b) distribute
+verbatim copies of these files to third parties. As a condition to the
+foregoing grant, you must provide this notice along with each copy you
+distribute and you must not remove, alter, or obscure this notice. All
+other use, reproduction, modification, distribution, or other
+exploitation of these files is strictly prohibited, except as may be set
+forth in a separate written license agreement between you and New
+Relic. The terms of any such license agreement will control over this
+notice. The license stated above will be automatically terminated and
+revoked if you exceed its scope or violate any of the terms of this
+notice.
+
+This License does not grant permission to use the trade names,
+trademarks, service marks, or product names of New Relic, except as
+required for reasonable and customary use in describing the origin of
+this file and reproducing the content of this notice. You may not
+mark or brand this file with any trade name, trademarks, service
+marks, or product names other than the original brand (if any)
+provided by New Relic.
+
+Unless otherwise expressly agreed by New Relic in a separate written
+license agreement, these files are provided AS IS, WITHOUT WARRANTY OF
+ANY KIND, including without any implied warranties of MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE, TITLE, or NON-INFRINGEMENT. As a
+condition to your use of these files, you are solely responsible for
+such use. New Relic will have no liability to you for direct,
+indirect, consequential, incidental, special, or punitive damages or
+for lost profits or data.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecd00502fc96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=python2-newrelic
+pkgver=2.52.0.40
+pkgrel=1
+pkgdesc="Python agent for the New Relic web application performance monitoring service."
+arch=('i686' 'x86_64')
+url="http://newrelic.com/docs/python/new-relic-for-python"
+license=("custom")
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("http://download.newrelic.com/python_agent/release/newrelic-${pkgver}.tar.gz"
+ LICENSE)
+
+package() {
+ cd newrelic-$pkgver
+ python2 setup.py install -O1 --root="$pkgdir"
+ install -Dm644 "$srcdir/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+sha512sums=('0cd6c54b45fb0d33c3eee325666256ab2ad3f04815ac80bf8f9974cf934ab708f29ed58b7d71f7866e4dcf8295ff3f562e47ddaccdc6293f639db7b28585ae24'
+ 'a9d8e4cf71c6bbb372aeb62fca5ced760ea00f406938d28cff57b9d9097abff1580649585f760e0131d59ff764aa2f5249b0ef19233981800211ede66633402b')