summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--COPYING32
-rw-r--r--PKGBUILD34
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b648337263f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python2-nilearn
+ pkgdesc = Python library for fast and easy statistical learning on NeuroImaging data
+ pkgver = 0.1.4.post1
+ pkgrel = 1
+ url = http://nilearn.github.io/
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = python2-scikit-learn>=0.12
+ depends = python2-nibabel>=1.10
+ optdepends = python2-matplotlib: Plotting library for fancy examples
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/n/nilearn/nilearn-0.1.4.post1.tar.gz
+ source = COPYING
+ md5sums = 26c276f23fecc5b3e89be22c41a8a42e
+ md5sums = 33ec80ab58266e76a552ebea227b6219
+ sha256sums = 50a1aec049ffb5691a57113aed5fa3a028add157127310b8c97e2dc4d3a9fc24
+ sha256sums = aff97bef794ee828d62ff0f4e8482ddc0f69cc27f9f016dc9e2c04ba5a84e6d4
+
+pkgname = python2-nilearn
+
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..ff49b87c96a6
--- /dev/null
+++ b/COPYING
@@ -0,0 +1,32 @@
+New BSD License
+
+Copyright (c) 2007 - 2013 The nilearn developers.
+All rights reserved.
+
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+ a. Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+ b. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ c. Neither the name of the nilearn Developers nor the names of
+ its contributors may be used to endorse or promote products
+ derived from this software without specific prior written
+ permission.
+
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR
+ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
+DAMAGE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb998d1676d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Konstantin Shmelkov <konstantin@shmelkov.net>
+pkgname=python2-nilearn
+pkgver=0.1.4.post1
+pkgrel=1
+pkgdesc="Python library for fast and easy statistical learning on NeuroImaging data"
+arch=('any')
+url="http://nilearn.github.io/"
+license=('BSD')
+depends=('python2-scikit-learn>=0.12' 'python2-nibabel>=1.10')
+makedepends=('python2-setuptools')
+optdepends=('python2-matplotlib: Plotting library for fancy examples')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/n/nilearn/nilearn-${pkgver}.tar.gz" "COPYING")
+md5sums=('26c276f23fecc5b3e89be22c41a8a42e'
+ '33ec80ab58266e76a552ebea227b6219')
+sha256sums=('50a1aec049ffb5691a57113aed5fa3a028add157127310b8c97e2dc4d3a9fc24'
+ 'aff97bef794ee828d62ff0f4e8482ddc0f69cc27f9f016dc9e2c04ba5a84e6d4')
+
+build() {
+ cd "$srcdir"/nilearn-$pkgver
+
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir"/nilearn-$pkgver
+
+ python2 setup.py install --root="$pkgdir"/ --optimize=1
+
+ #sed -i -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ #$(find "${pkgdir}" -name '*.py')
+
+ install -m644 -D "$srcdir/COPYING" "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}