summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..916a03cee933
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-odfpy
+ pkgdesc = A complete API for OpenDocument in Python. Python 2.x support
+ pkgver = 0.9.6
+ pkgrel = 1
+ url = http://opendocumentfellowship.com/projects/odfpy
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2
+ conflicts = odfpy
+ conflicts = python-odfpy
+ conflicts = python3-odfpy
+ conflicts = python-all-odfpy
+ source = http://pypi.python.org/packages/source/o/odfpy/odfpy-0.9.6.tar.gz
+ md5sums = 3f570ead2b5f5eb6eab97eecce22d491
+
+pkgname = python2-odfpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28617e30ce59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Vinicius de Avila <vinicius.avila.jorge@gmail.com>
+# Update Based on Geoff Teale's PKGBUILD. To support only python2
+pkgname=python2-odfpy
+pkgver=0.9.6
+pkgrel=1
+pkgdesc="A complete API for OpenDocument in Python. Python 2.x support"
+arch=('i686' 'x86_64')
+url="http://opendocumentfellowship.com/projects/odfpy"
+license=('GPL')
+depends=('python2')
+conflicts=('odfpy' 'python-odfpy' 'python3-odfpy' 'python-all-odfpy')
+source=("http://pypi.python.org/packages/source/o/odfpy/odfpy-$pkgver.tar.gz")
+md5sums=('3f570ead2b5f5eb6eab97eecce22d491')
+
+build() {
+ cd "$srcdir/odfpy-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/odfpy-${pkgver}"
+ python2 setup.py install --root=${pkgdir}
+}