summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD39
2 files changed, 32 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e63417fc07d8..7377616747ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = python2-pkgconfig
pkgdesc = Python 2 module to interface with the pkg-config command line tool
- pkgver = 1.5.1
+ pkgver = 1.5.2
pkgrel = 1
url = https://github.com/matze/pkgconfig
arch = any
license = MIT
makedepends = python2-setuptools
depends = python2
- source = https://files.pythonhosted.org/packages/source/p/pkgconfig/pkgconfig-1.5.1.tar.gz
- sha256sums = 97bfe3d981bab675d5ea3ef259045d7919c93897db7d3b59d4e8593cba8d354f
+ source = https://files.pythonhosted.org/packages/source/p/pkgconfig/pkgconfig-1.5.2.tar.gz
+ sha256sums = 38d612488f0633755a2e7a8acab6c01d20d63dbc31af75e2a9ac98a6f638ca94
pkgname = python2-pkgconfig
diff --git a/PKGBUILD b/PKGBUILD
index 52d9bc18f44d..75237aa9f839 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,29 @@
+# SPDX-License-Identifier: AGPL-3.0
+#
# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+# Maintainer: Truocolo <truocolo@aol.com>
# Contributor: Infernio <infernio at icloud dot com>
# Contributor: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Marcell Meszaros (MarsSeed) <marcell.meszaros@runbox.eu>
_py="python2"
_pkg="pkgconfig"
pkgname="${_py}-${_pkg}"
-pkgver=1.5.1
+pkgver=1.5.2
pkgrel=1
-pkgdesc="Python 2 module to interface with the pkg-config command line tool"
-arch=(any)
+_pkgdesc=(
+ "Python 2 module to interface with"
+ "the pkg-config command line tool"
+)
+pkgdesc="${_pkgdesc[*]}"
+arch=(
+ any
+)
_ns="matze"
url="https://github.com/${_ns}/${_pkg}"
-license=(MIT)
+license=(
+ MIT
+)
depends=(
"${_py}"
)
@@ -23,16 +35,23 @@ source=(
"${_pypi_url}/${_pkg::1}/${_pkg}/${_pkg}-${pkgver}.tar.gz"
)
sha256sums=(
- '97bfe3d981bab675d5ea3ef259045d7919c93897db7d3b59d4e8593cba8d354f'
+ '38d612488f0633755a2e7a8acab6c01d20d63dbc31af75e2a9ac98a6f638ca94'
)
package() {
- cd "${_pkg}-${pkgver}"
+ cd \
+ "${_pkg}-${pkgver}"
- "${_py}" setup.py install --prefix=/usr \
- --root="${pkgdir}" \
- --optimize=1
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ "${_py}" \
+ setup.py \
+ install \
+ --prefix=/usr \
+ --root="${pkgdir}" \
+ --optimize=1
+ install \
+ -Dm644 \
+ LICENSE \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set sw=2 sts=-1 et: