summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--remove-argparse.patch26
3 files changed, 39 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 631abe1c8411..0761034f90c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Feb 9 21:32:49 UTC 2016
+# Wed Mar 30 05:54:42 UTC 2016
pkgbase = python2-pwntools
pkgdesc = The CTF framework used by Gallopsled in every CTF
pkgver = 2.2.0
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/Gallopsled/pwntools/
arch = any
license = MIT
@@ -24,7 +24,9 @@ pkgbase = python2-pwntools
conflicts = python2-pwntools-git
options = strip
source = https://github.com/Gallopsled/pwntools/archive/2.2.0.tar.gz
+ source = remove-argparse.patch
md5sums = 3ab358401ec751436f71633fb7476c28
+ md5sums = b0d3d53980787e7fd841526e4d92b194
pkgname = python2-pwntools
diff --git a/PKGBUILD b/PKGBUILD
index 025239d59f9a..885f0c7640a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: jerry73204 <jerry73204@gmail.com>
pkgname=python2-pwntools
pkgver=2.2.0
-pkgrel=4
-pkgdesc="The CTF framework used by Gallopsled in every CTF"
+pkgrel=5
+pkgdesc='The CTF framework used by Gallopsled in every CTF'
arch=('any')
-url="https://github.com/Gallopsled/pwntools/"
+url='https://github.com/Gallopsled/pwntools/'
license=('MIT' 'GPL2' 'BSD')
makedepends=('lib32-glibc'
'python2-setuptools')
@@ -19,13 +19,16 @@ depends=('python2>=2.7'
'ropgadget')
conflicts=('python2-pwntools' 'python2-pwntools-git')
options=('strip')
-source=("https://github.com/Gallopsled/pwntools/archive/${pkgver}.tar.gz")
-md5sums=('3ab358401ec751436f71633fb7476c28')
+source=("https://github.com/Gallopsled/pwntools/archive/${pkgver}.tar.gz"
+ 'remove-argparse.patch')
+md5sums=('3ab358401ec751436f71633fb7476c28'
+ 'b0d3d53980787e7fd841526e4d92b194')
_repodir="pwntools-${pkgver}"
prepare() {
cd "${srcdir}/${_repodir}"
+ patch -Np1 < "${srcdir}/remove-argparse.patch"
sed -i "s/'capstone==2.1'/'capstone'/" setup.py
}
@@ -33,6 +36,7 @@ package() {
cd "${srcdir}/${_repodir}"
python2 setup.py install --root="${pkgdir}/" --optimize=1
install -D -m 644 LICENSE-pwntools.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm "${pkgdir}/usr/lib/python"*"/site-packages/LICENSE-pwntools.txt"
# rename binaries to avoid filename confliction
for bin in "${pkgdir}/usr/bin/"*; do
diff --git a/remove-argparse.patch b/remove-argparse.patch
new file mode 100644
index 000000000000..4ac64c1be91f
--- /dev/null
+++ b/remove-argparse.patch
@@ -0,0 +1,26 @@
+diff --git a/docs/requirements.txt b/docs/requirements.txt
+index 6c1e3b1..3de1462 100644
+--- a/docs/requirements.txt
++++ b/docs/requirements.txt
+@@ -1,6 +1,5 @@
+ paramiko
+-argparse
+ mako
+ pyelftools
+ sphinxcontrib-napoleon
+-sphinxcontrib-autoprogram
+\ No newline at end of file
++sphinxcontrib-autoprogram
+diff --git a/setup.py b/setup.py
+index 28dcacf..450cfe7 100644
+--- a/setup.py
++++ b/setup.py
+@@ -32,7 +32,7 @@ for filename in glob.glob('pwnlib/commandline/*'):
+ script = '%s=pwnlib.commandline.%s:main' % (filename, filename)
+ console_scripts.append(script)
+
+-install_requires = ['paramiko','argparse', 'mako', 'pyelftools',
++install_requires = ['paramiko', 'mako', 'pyelftools',
+ 'capstone==2.1', 'ropgadget', 'pyserial', 'requests']
+
+ # This is a hack until somebody ports psutil to OpenBSD