summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD9
-rw-r--r--remove-argparse.patch28
3 files changed, 17 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0761034f90c1..5dfa7269e532 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Mar 30 05:54:42 UTC 2016
+# Mon Jul 4 10:29:04 UTC 2016
pkgbase = python2-pwntools
pkgdesc = The CTF framework used by Gallopsled in every CTF
- pkgver = 2.2.0
- pkgrel = 5
+ pkgver = 2.3.0
+ pkgrel = 1
url = https://github.com/Gallopsled/pwntools/
arch = any
license = MIT
@@ -23,10 +23,10 @@ pkgbase = python2-pwntools
conflicts = python2-pwntools
conflicts = python2-pwntools-git
options = strip
- source = https://github.com/Gallopsled/pwntools/archive/2.2.0.tar.gz
+ source = https://github.com/Gallopsled/pwntools/archive/2.3.0.tar.gz
source = remove-argparse.patch
- md5sums = 3ab358401ec751436f71633fb7476c28
- md5sums = b0d3d53980787e7fd841526e4d92b194
+ sha1sums = bb15fb7365093e1ddc7417896843e5e3868bec72
+ sha1sums = 42ba67adb748fdc31a95ecb108814ca33eee5c36
pkgname = python2-pwntools
diff --git a/PKGBUILD b/PKGBUILD
index 885f0c7640a5..9f39a27e2964 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: jerry73204 <jerry73204@gmail.com>
pkgname=python2-pwntools
-pkgver=2.2.0
-pkgrel=5
+pkgver=2.3.0
+pkgrel=1
pkgdesc='The CTF framework used by Gallopsled in every CTF'
arch=('any')
url='https://github.com/Gallopsled/pwntools/'
@@ -21,15 +21,14 @@ conflicts=('python2-pwntools' 'python2-pwntools-git')
options=('strip')
source=("https://github.com/Gallopsled/pwntools/archive/${pkgver}.tar.gz"
'remove-argparse.patch')
-md5sums=('3ab358401ec751436f71633fb7476c28'
- 'b0d3d53980787e7fd841526e4d92b194')
+sha1sums=('bb15fb7365093e1ddc7417896843e5e3868bec72'
+ '42ba67adb748fdc31a95ecb108814ca33eee5c36')
_repodir="pwntools-${pkgver}"
prepare() {
cd "${srcdir}/${_repodir}"
patch -Np1 < "${srcdir}/remove-argparse.patch"
- sed -i "s/'capstone==2.1'/'capstone'/" setup.py
}
package() {
diff --git a/remove-argparse.patch b/remove-argparse.patch
index 4ac64c1be91f..94db50cd5de8 100644
--- a/remove-argparse.patch
+++ b/remove-argparse.patch
@@ -1,26 +1,12 @@
-diff --git a/docs/requirements.txt b/docs/requirements.txt
-index 6c1e3b1..3de1462 100644
---- a/docs/requirements.txt
-+++ b/docs/requirements.txt
-@@ -1,6 +1,5 @@
- paramiko
--argparse
- mako
- pyelftools
- sphinxcontrib-napoleon
--sphinxcontrib-autoprogram
-\ No newline at end of file
-+sphinxcontrib-autoprogram
diff --git a/setup.py b/setup.py
-index 28dcacf..450cfe7 100644
+index fed5c02..cf075b7 100644
--- a/setup.py
+++ b/setup.py
-@@ -32,7 +32,7 @@ for filename in glob.glob('pwnlib/commandline/*'):
- script = '%s=pwnlib.commandline.%s:main' % (filename, filename)
+@@ -33,7 +33,6 @@ for filename in glob.glob('pwnlib/commandline/*'):
console_scripts.append(script)
--install_requires = ['paramiko','argparse', 'mako', 'pyelftools',
-+install_requires = ['paramiko', 'mako', 'pyelftools',
- 'capstone==2.1', 'ropgadget', 'pyserial', 'requests']
-
- # This is a hack until somebody ports psutil to OpenBSD
+ install_requires = ['paramiko>=1.15.2',
+- 'argparse',
+ 'mako>=1.0.0',
+ 'pyelftools>=0.2.3',
+ 'capstone',