summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 11 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e64dedbcc2b..4ce0058cd9db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Jan 2 17:34:03 UTC 2017
+# Fri Mar 10 12:08:45 UTC 2017
pkgbase = python2-pwntools
pkgdesc = The CTF framework used by Gallopsled in every CTF
- pkgver = 3.3.0
+ pkgver = 3.4.1
pkgrel = 1
url = https://pwntools.com/
arch = any
@@ -29,8 +29,8 @@ pkgbase = python2-pwntools
conflicts = python2-pwntools
conflicts = python2-pwntools-git
options = strip
- source = https://github.com/Gallopsled/pwntools/archive/3.3.0.tar.gz
- sha256sums = 323775fb33ef289065a39817ff0b53a4e1bf6383723ba9553b7e1c1ef1b8bc24
+ source = https://github.com/Gallopsled/pwntools/archive/3.4.1.tar.gz
+ sha256sums = 54e741557609af73c1817ff9f5a4087390ba9cb0f1b11264ab5bbf225e326bec
pkgname = python2-pwntools
diff --git a/PKGBUILD b/PKGBUILD
index 7c9838ab2383..bf010e57b852 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: jerry73204 <jerry73204@gmail.com>
pkgname=python2-pwntools
-pkgver=3.3.0
+pkgver=3.4.1
pkgrel=1
pkgdesc='The CTF framework used by Gallopsled in every CTF'
arch=('any')
@@ -26,24 +26,17 @@ depends=('python2>=2.7'
conflicts=('python2-pwntools' 'python2-pwntools-git')
options=('strip')
source=("https://github.com/Gallopsled/pwntools/archive/${pkgver}.tar.gz")
-sha256sums=('323775fb33ef289065a39817ff0b53a4e1bf6383723ba9553b7e1c1ef1b8bc24')
+sha256sums=('54e741557609af73c1817ff9f5a4087390ba9cb0f1b11264ab5bbf225e326bec')
_repodir="pwntools-${pkgver}"
prepare() {
- cd "${srcdir}/${_repodir}"
- # patch -Np1 < "${srcdir}/remove-argparse.patch"
+ cd ${srcdir}/${_repodir}
}
package() {
- cd "${srcdir}/${_repodir}"
- python2 setup.py install --root="${pkgdir}/" --optimize=1
- install -D -m 644 LICENSE-pwntools.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- rm "${pkgdir}/usr/lib/python"*"/site-packages/LICENSE-pwntools.txt"
-
- # rename binaries to avoid filename confliction
- for bin in "${pkgdir}/usr/bin/"*; do
- msg "rename binary ${bin##*/} to pwn-${bin##*/}"
- mv "$bin" "${bin%/*}/pwn-${bin##*/}"
- done
+ cd ${srcdir}/${_repodir}
+ python2 setup.py install --root=${pkgdir}/ --optimize=1 --only-use-pwn-command
+ install -D -m 644 LICENSE-pwntools.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm ${pkgdir}/usr/lib/python*/site-packages/LICENSE-pwntools.txt
}