summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..249c0083b615
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-pygal
+ pkgdesc = pygal is a dynamic SVG charting library written in python
+ pkgver = 2.4.0
+ pkgrel = 1
+ url = http://www.pygal.org/en/stable/
+ arch = any
+ license = LGPL3
+ makedepends = python2-setuptools
+ depends = python2
+ conflicts = python2-pygal
+ conflicts = python2-pygal-git
+ source = https://github.com/Kozea/pygal/archive/2.4.0.tar.gz
+ sha256sums = 16d29d72abc2e2bd5e296a68e62b5b98d797385295084eb7853fd4e221b471f7
+
+pkgname = python2-pygal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..452d2bcdf0ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Valerii Huz <ghotrix@gmail.com>
+pkgname=python2-pygal
+pkgver=2.4.0
+pkgrel=1
+pkgdesc="pygal is a dynamic SVG charting library written in python"
+arch=("any")
+url="http://www.pygal.org/en/stable/"
+license=("LGPL3")
+depends=("python2")
+makedepends=("python2-setuptools")
+optdepend=("python2-lxml")
+conflicts=("${pkgname}" "${pkgname}-git")
+source=("https://github.com/Kozea/pygal/archive/$pkgver.tar.gz")
+sha256sums=("16d29d72abc2e2bd5e296a68e62b5b98d797385295084eb7853fd4e221b471f7")
+
+build() {
+ cd "${srcdir}/pygal-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/pygal-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+}