summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD18
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51d02781b868
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-pylastfp
+ pkgdesc = A Python interface to Last.fm's acoustic fingerprinting library and its related API servicesa
+ pkgver = 0.6
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/pylastfp
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ makedepends = python2
+ depends = python2
+ depends = libsamplerate
+ depends = fftw
+ source = https://pypi.python.org/packages/source/p/pylastfp/pylastfp-0.6.tar.gz
+ md5sums = 292946bd34f24f533029085e063d5155
+
+pkgname = python2-pylastfp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8552022dda3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Contributer: Adria Arrufat <swiftscythe@gmail.com>
+
+pkgname=python2-pylastfp
+pkgver=0.6
+pkgrel=1
+pkgdesc="A Python interface to Last.fm's acoustic fingerprinting library and its related API servicesa"
+arch=(i686 x86_64)
+url="https://pypi.python.org/pypi/pylastfp"
+license=('APACHE')
+makedepends=('python2')
+depends=('python2' 'libsamplerate' 'fftw')
+source=(https://pypi.python.org/packages/source/p/pylastfp/pylastfp-${pkgver}.tar.gz)
+
+build() {
+ cd $startdir/src/pylastfp-$pkgver
+ python2 setup.py install --root=$startdir/pkg --optimize=1
+}
+md5sums=('292946bd34f24f533029085e063d5155')