summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
-rw-r--r--license.txt32
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df1c1617850c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-qserve
+ pkgdesc = job queue server
+ pkgver = 0.2.8
+ pkgrel = 1
+ url = https://github.com/pediapress/qserve
+ arch = any
+ license = unknown
+ makedepends = python2-setuptools
+ depends = python2
+ source = https://pypi.python.org/packages/source/q/qserve/qserve-0.2.8.zip
+ source = license.txt
+ md5sums = d481f0dad66a93d0479022fe0487e8ee
+ md5sums = 2b333de6f7b8cec3820857fc249ac2d3
+
+pkgname = python2-qserve
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98c5ffe1370a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname='python2-qserve'
+_module='qserve'
+pkgver='0.2.8'
+pkgrel=1
+pkgdesc="job queue server"
+url="https://github.com/pediapress/qserve"
+depends=('python2')
+makedepends=('python2-setuptools')
+license=('unknown')
+arch=('any')
+source=("https://pypi.python.org/packages/source/q/qserve/qserve-${pkgver}.zip"
+ license.txt)
+md5sums=('d481f0dad66a93d0479022fe0487e8ee'
+ '2b333de6f7b8cec3820857fc249ac2d3')
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ install -D -m644 "${srcdir}/license.txt" \ /usr/share/licenses/${pkgname}/license.txt
+}
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..a11e1fa25a10
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,32 @@
+Copyright (c) PediaPress GmbH
+
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+
+* Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+* Redistributions in binary form must reproduce the above
+ copyright notice, this list of conditions and the following
+ disclaimer in the documentation and/or other materials provided
+ with the distribution.
+
+* Neither the name of PediaPress GmbH nor the names of its
+ contributors may be used to endorse or promote products derived
+ from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
+CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+