summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 22 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f4793392af0..df23d2c229e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = python2-rabbitpy
pkgdesc = A pure python, thread-safe, minimalistic and pythonic RabbitMQ client library
- pkgver = 0.26.2
+ pkgver = 2.0.1
pkgrel = 1
- url = http://rabbitpy.readthedocs.org
+ url = https://github.com/gmr/rabbitpy
arch = any
- license = CUSTOM
- makedepends = python2-distribute
+ license = custom
+ makedepends = python2-setuptools
depends = python2
- source = https://pypi.python.org/packages/source/r/rabbitpy/rabbitpy-0.26.2.tar.gz
- md5sums = 6430a629d8d7b4c7f6db8e87a28c1b4d
+ source = https://pypi.org/packages/source/r/rabbitpy/rabbitpy-2.0.1.tar.gz
+ sha512sums = b0ff11d7e2c063db654d2668178101eedc4ff3e3b609a5615e4876eda82491260d74da11d5c892721b6d7f6947efabe0a9f7875992f84c1fcd0e51478bb88f56
pkgname = python2-rabbitpy
-
diff --git a/PKGBUILD b/PKGBUILD
index 5514af4b1145..f89b1558d634 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
-#Automatically generated by pip2arch on 2014-12-11
+# Contributor: Daichi Shinozaki <dsdseg@gmail.com>
-pkgname=python2-rabbitpy
-pkgver=0.26.2
+_base=rabbitpy
+pkgname=python2-${_base}
+pkgver=2.0.1
pkgrel=1
pkgdesc="A pure python, thread-safe, minimalistic and pythonic RabbitMQ client library"
-url="http://rabbitpy.readthedocs.org"
-depends=('python2' )
-makedepends=('python2-distribute' )
-license=('CUSTOM')
-arch=('any')
-source=("https://pypi.python.org/packages/source/r/rabbitpy/rabbitpy-$pkgver.tar.gz")
-md5sums=('39bceee9daa496c53158308d0962dbf8')
+arch=(any)
+url="https://github.com/gmr/${_base}"
+depends=(python2) # -pamqp
+makedepends=(python2-setuptools)
+license=('custom')
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha512sums=('b0ff11d7e2c063db654d2668178101eedc4ff3e3b609a5615e4876eda82491260d74da11d5c892721b6d7f6947efabe0a9f7875992f84c1fcd0e51478bb88f56')
build() {
- cd $srcdir/rabbitpy-$pkgver
- python2 setup.py build
+ cd ${_base}-${pkgver}
+ python2 setup.py build
}
package() {
- cd $srcdir/rabbitpy-$pkgver
- python2 setup.py install --root="$pkgdir" --optimize=1
+ cd ${_base}-${pkgver}
+ python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}