summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD25
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42973f06cfe6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python2-rasterio
+ pkgdesc = Fast and direct raster I/O for use with Numpy and SciPy (Python 2)
+ pkgver = 1.0a5
+ pkgrel = 1
+ url = https://github.com/mapbox/rasterio
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python2-setuptools
+ makedepends = cython2
+ depends = python2-affine
+ depends = python2-cligj
+ depends = python2-numpy
+ depends = python2-snuggs
+ depends = python2-click-plugins
+ depends = python2-enum34
+ depends = gdal
+ options = !emptydirs
+ source = https://github.com/mapbox/rasterio/archive/1.0a5.zip
+ sha256sums = d773506efa63ee0d367b32c34ae40ff4a2f61254be3a01f038dc68eb9ba1fbb0
+
+pkgname = python2-rasterio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2bcefea26f32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
+pkgname=('python2-rasterio')
+pkgver=1.0a5
+pkgrel=1
+pkgdesc="Fast and direct raster I/O for use with Numpy and SciPy (Python 2)"
+arch=('i686' 'x86_64')
+url="https://github.com/mapbox/rasterio"
+license=('BSD')
+makedepends=('python2-setuptools' 'cython2')
+depends=('python2-affine' 'python2-cligj' 'python2-numpy' 'python2-snuggs'
+ 'python2-click-plugins' 'python2-enum34' 'gdal')
+options=(!emptydirs)
+source=("$url/archive/$pkgver.zip")
+sha256sums=('d773506efa63ee0d367b32c34ae40ff4a2f61254be3a01f038dc68eb9ba1fbb0')
+
+build() {
+ cd "$srcdir/rasterio-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/rasterio-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}