summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD24
3 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 999e2ff21569..07ea79836364 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
-# Generated by makepkg 4.2.1
-# Tue May 26 13:40:14 UTC 2015
pkgbase = python2-regex
pkgdesc = Alternative regular expression module, to replace re.
- pkgver = 0.1.20141024
+ pkgver = 2020.11.13
pkgrel = 1
url = https://bitbucket.org/mrabarnett/mrab-regex
- arch = i686
- arch = x86_64
- license = custom
- makedepends = python2-distribute
+ arch = any
+ license = Python
+ license = Apache
+ makedepends = python2-setuptools
depends = python2
- conflicts = python2-regex-hg
- source = https://launchpad.net/ubuntu/+archive/primary/+files/python-regex_0.1.20141024.orig.tar.gz
- sha256sums = 8bd2dbf096bcfa881bd7e06093037037a7315e82d0e74441338f4b6492037801
+ source = https://files.pythonhosted.org/packages/source/r/regex/regex-2020.11.13.tar.gz
+ sha256sums = 83d6b356e116ca119db8e7c6fc2983289d87b27b3fac238cfe5dca529d884562
pkgname = python2-regex
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e0b41e25a64f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.tar.gz
+*.tar.xz
+*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index fc53d59ec78c..6a7cfbf165d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
-# Contributor: Spyros Stathopoulos <foucault.online@gmail.com>
pkgname=python2-regex
-pkgver=0.1.20141024
+pkgver=2020.11.13
pkgrel=1
pkgdesc="Alternative regular expression module, to replace re."
-arch=('i686' 'x86_64')
url="https://bitbucket.org/mrabarnett/mrab-regex"
-license=('custom')
depends=('python2')
-makedepends=('python2-distribute')
-conflicts=('python2-regex-hg')
-source=("https://launchpad.net/ubuntu/+archive/primary/+files/python-regex_${pkgver}.orig.tar.gz")
-sha256sums=('8bd2dbf096bcfa881bd7e06093037037a7315e82d0e74441338f4b6492037801')
+makedepends=('python2-setuptools')
+license=('Python' 'Apache')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/r/regex/regex-${pkgver}.tar.gz")
+sha256sums=('83d6b356e116ca119db8e7c6fc2983289d87b27b3fac238cfe5dca529d884562')
build() {
- cd "$srcdir/regex-2014.10.24"
+ cd "${srcdir}/regex-${pkgver}"
- python2 setup.py build
+ python2 setup.py build
}
package() {
- cd "${srcdir}/regex-2014.10.24"
+ cd "${srcdir}/regex-${pkgver}"
- python2 setup.py install --prefix=/usr --root="${pkgdir}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.txt
}
-