summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD18
3 files changed, 53 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..ee7c60ec548f
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-rtmpy
+ pkgdesc = A Python module that provides RTMP support
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/hydralabs/rtmpy
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = setuptools
+ depends = python2
+ depends = python2-pyamf
+ depends = twisted
+ depends = zope-interface
+ source = http://pypi.python.org/packages/source/R/RTMPy/RTMPy-0.1.1.tar.gz
+
+pkgname = python2-rtmpy
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..122a2a1da217
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-rtmpy
+ pkgdesc = A Python module that provides RTMP support
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/hydralabs/rtmpy
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = setuptools
+ depends = python2
+ depends = python2-pyamf
+ depends = twisted
+ depends = zope-interface
+ source = http://pypi.python.org/packages/source/R/RTMPy/RTMPy-0.1.1.tar.gz
+ md5sums = c1e3e2a93b9174b0799007af15989f3a
+
+pkgname = python2-rtmpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66ba14a351d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=python2-rtmpy
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="A Python module that provides RTMP support"
+depends=('python2' 'python2-pyamf' 'twisted' 'zope-interface')
+makedepends=('setuptools')
+source=("http://pypi.python.org/packages/source/R/RTMPy/RTMPy-${pkgver}.tar.gz")
+url="https://github.com/hydralabs/rtmpy"
+license=('LGPL2.1')
+arch=('i686' 'x86_64')
+md5sums=('c1e3e2a93b9174b0799007af15989f3a')
+
+package() {
+ cd "$srcdir"/RTMPy-$pkgver
+ python2 setup.py install --root "${pkgdir}"
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname
+ cp $srcdir/RTMPy-$pkgver/LICENSE.txt $pkgdir/usr/share/licenses/$pkgname
+}