summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
-rw-r--r--wx.patch11
3 files changed, 10 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad786a326c9c..98c1b67416ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = python2-runsnakerun
pkgdesc = GUI Viewer for Python profiling runs
pkgver = 2.0.4
- pkgrel = 1
+ pkgrel = 2
url = http://www.vrplumber.com/programming/runsnakerun/
arch = any
license = BSD
depends = python2-squaremap
- depends = wxpython2.8
- source = http://pypi.python.org/packages/source/R/RunSnakeRun/RunSnakeRun-2.0.4.tar.gz
- source = wx.patch
+ depends = wxpython
+ source = https://files.pythonhosted.org/packages/source/R/RunSnakeRun/RunSnakeRun-2.0.4.tar.gz
md5sums = 3220b5b89994baee70b1c24d7e42a306
- md5sums = 6d00db360df47ae79f52e398bf23f845
pkgname = python2-runsnakerun
diff --git a/PKGBUILD b/PKGBUILD
index bcf2420119cc..a31e062b0286 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,24 @@
pkgname=python2-runsnakerun
+_name=RunSnakeRun
pkgver=2.0.4
-pkgrel=1
+pkgrel=2
pkgdesc="GUI Viewer for Python profiling runs"
arch=('any')
url="http://www.vrplumber.com/programming/runsnakerun/"
license=('BSD')
-depends=('python2-squaremap' 'wxpython2.8')
-source=("http://pypi.python.org/packages/source/R/RunSnakeRun/RunSnakeRun-$pkgver.tar.gz"
- "wx.patch")
+depends=('python2-squaremap' 'wxpython')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('3220b5b89994baee70b1c24d7e42a306')
+
build() {
cd "$srcdir/RunSnakeRun-$pkgver"
- msg "Patching source code..."
- patch -p0 < ${srcdir}/wx.patch
-
- msg "Building..."
python2 setup.py build
}
package() {
cd "$srcdir/RunSnakeRun-$pkgver"
- python2 setup.py install --root=$pkgdir/ --optimize=1
+ python2 setup.py install --root=$pkgdir/ --optimize=1 --skip-build
}
-
-md5sums=('3220b5b89994baee70b1c24d7e42a306'
- '6d00db360df47ae79f52e398bf23f845')
diff --git a/wx.patch b/wx.patch
deleted file mode 100644
index 109e5ae47e95..000000000000
--- a/wx.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- runsnakerun/runsnake.py 2013-10-25 15:55:49.000000000 +0200
-+++ runsnakerun/runsnake.py 2014-06-06 00:51:54.291448727 +0200
-@@ -2,6 +2,8 @@
- """The main script for the RunSnakeRun profile viewer"""
-
-+import wxversion
-+wxversion.select("2.8")
- import wx, sys, os, logging, traceback
- log = logging.getLogger( __name__ )
- import ConfigParser
- try: