summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--wx.patch11
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad786a326c9c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-runsnakerun
+ pkgdesc = GUI Viewer for Python profiling runs
+ pkgver = 2.0.4
+ pkgrel = 1
+ url = http://www.vrplumber.com/programming/runsnakerun/
+ arch = any
+ license = BSD
+ depends = python2-squaremap
+ depends = wxpython2.8
+ source = http://pypi.python.org/packages/source/R/RunSnakeRun/RunSnakeRun-2.0.4.tar.gz
+ source = wx.patch
+ md5sums = 3220b5b89994baee70b1c24d7e42a306
+ md5sums = 6d00db360df47ae79f52e398bf23f845
+
+pkgname = python2-runsnakerun
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcf2420119cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=python2-runsnakerun
+pkgver=2.0.4
+pkgrel=1
+pkgdesc="GUI Viewer for Python profiling runs"
+arch=('any')
+url="http://www.vrplumber.com/programming/runsnakerun/"
+license=('BSD')
+depends=('python2-squaremap' 'wxpython2.8')
+source=("http://pypi.python.org/packages/source/R/RunSnakeRun/RunSnakeRun-$pkgver.tar.gz"
+ "wx.patch")
+
+build() {
+ cd "$srcdir/RunSnakeRun-$pkgver"
+
+ msg "Patching source code..."
+ patch -p0 < ${srcdir}/wx.patch
+
+ msg "Building..."
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/RunSnakeRun-$pkgver"
+
+ python2 setup.py install --root=$pkgdir/ --optimize=1
+}
+
+md5sums=('3220b5b89994baee70b1c24d7e42a306'
+ '6d00db360df47ae79f52e398bf23f845')
diff --git a/wx.patch b/wx.patch
new file mode 100644
index 000000000000..109e5ae47e95
--- /dev/null
+++ b/wx.patch
@@ -0,0 +1,11 @@
+--- runsnakerun/runsnake.py 2013-10-25 15:55:49.000000000 +0200
++++ runsnakerun/runsnake.py 2014-06-06 00:51:54.291448727 +0200
+@@ -2,6 +2,8 @@
+ """The main script for the RunSnakeRun profile viewer"""
+
++import wxversion
++wxversion.select("2.8")
+ import wx, sys, os, logging, traceback
+ log = logging.getLogger( __name__ )
+ import ConfigParser
+ try: