summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9967e9d535ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-sloppycell
+ pkgdesc = Software environment for simulation and analysis of biomolecular networks
+ pkgver = 20110614
+ pkgrel = 1
+ url = http://sloppycell.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = cvs
+ makedepends = gcc-fortran
+ depends = python2-scipy
+ depends = python2-numpy
+ depends = lapack
+
+pkgname = python2-sloppycell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..996ee17f38bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Michael Schubert <mschu.dev at gmail>
+
+pkgname=python2-sloppycell
+pkgver=20110614
+pkgrel=1
+pkgdesc="Software environment for simulation and analysis of biomolecular networks"
+arch=('i686' 'x86_64')
+url="http://sloppycell.sourceforge.net/"
+license=('BSD')
+depends=('python2-scipy' 'python2-numpy' 'lapack')
+makedepends=('cvs' 'gcc-fortran')
+
+_cvsroot=":pserver:anonymous@sloppycell.cvs.sourceforge.net:/cvsroot"
+_cvsmod="sloppycell"
+_cvsMod="SloppyCell"
+
+build() {
+ cd "$srcdir"
+ if [ -d ${_cvsMod}/CVS ]; then
+ cd ${_cvsMod}
+ cvs -q update -dA
+ else
+ cvs -q -z3 -d${_cvsroot}/${_cvsmod} co ${_cvsMod}
+ cd ${_cvsMod}
+ sed -i "/daskr =/s|$| extra_link_args='-Wl,--defsym,main=main',|" setup.py
+ fi
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_cvsMod"
+ python2 setup.py install --root="$pkgdir/" --skip-build --optimize=1
+}
+