summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d35224e85bc7..3f7dd0c36661 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,7 @@ pkgbase = python2-slowaes
depends = python2
source = https://pypi.python.org/packages/source/s/slowaes/slowaes-0.1a1.tar.gz
md5sums = eafee95a788a795403e972a35e80ce4f
+ sha256sums = 83658ae54cc116b96f7fdb12fdd0efac3a4e8c7c7064e3fac3f4a881aa54bf09
pkgname = python2-slowaes
diff --git a/PKGBUILD b/PKGBUILD
index 77202f531d77..3e14aa10ed10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# $Id: PKGBUILD 276332 2017-12-28 05:13:56Z eschwartz $
-# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Maintainer: kpcyrd <git@rxv.cc>
+# Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
# Contributor: Samuel Tardieu <sam@rfc1149.net>
pkgname=python2-slowaes
@@ -13,10 +13,15 @@ depends=('python2')
makedepends=('python2-setuptools')
source=("https://pypi.python.org/packages/source/s/slowaes/slowaes-$pkgver.tar.gz")
md5sums=('eafee95a788a795403e972a35e80ce4f')
+sha256sums=('83658ae54cc116b96f7fdb12fdd0efac3a4e8c7c7064e3fac3f4a881aa54bf09')
-package() {
+prepare() {
cd "$srcdir/slowaes-$pkgver"
sed -i 's#/usr/bin/python#/usr/bin/python2#' aes.py
+}
+
+package() {
+ cd "$srcdir/slowaes-$pkgver"
python2 setup.py install --root="$pkgdir/" --optimize=1
}