summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d35224e85bc7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-slowaes
+ pkgdesc = Implementation of AES in Python
+ pkgver = 0.1a1
+ pkgrel = 3
+ url = https://code.google.com/archive/p/slowaes/
+ arch = any
+ license = Apache
+ makedepends = python2-setuptools
+ depends = python2
+ source = https://pypi.python.org/packages/source/s/slowaes/slowaes-0.1a1.tar.gz
+ md5sums = eafee95a788a795403e972a35e80ce4f
+
+pkgname = python2-slowaes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77202f531d77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 276332 2017-12-28 05:13:56Z eschwartz $
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: Samuel Tardieu <sam@rfc1149.net>
+
+pkgname=python2-slowaes
+pkgver=0.1a1
+pkgrel=3
+pkgdesc="Implementation of AES in Python"
+arch=('any')
+url="https://code.google.com/archive/p/slowaes/"
+license=('Apache')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("https://pypi.python.org/packages/source/s/slowaes/slowaes-$pkgver.tar.gz")
+md5sums=('eafee95a788a795403e972a35e80ce4f')
+
+package() {
+ cd "$srcdir/slowaes-$pkgver"
+ sed -i 's#/usr/bin/python#/usr/bin/python2#' aes.py
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: