summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..266511dbc94b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-sqlite3dbm
+ pkgdesc = sqlite-backed dictionary
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = http://github.com/Yelp/sqlite3dbm/
+ arch = any
+ license = Apache
+ makedepends = python2-setuptools
+ depends = python2
+ source = https://pypi.python.org/packages/source/s/sqlite3dbm/sqlite3dbm-0.1.4.tar.gz
+ md5sums = fc2f8fb09a4bbc0260b97e835b369184
+
+pkgname = python2-sqlite3dbm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fc8004aad09
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+pkgname='python2-sqlite3dbm'
+_module='sqlite3dbm'
+pkgver='0.1.4'
+pkgrel=1
+pkgdesc="sqlite-backed dictionary"
+url="http://github.com/Yelp/sqlite3dbm/"
+depends=('python2')
+makedepends=('python2-setuptools')
+license=('Apache')
+arch=('any')
+source=("https://pypi.python.org/packages/source/s/sqlite3dbm/sqlite3dbm-${pkgver}.tar.gz")
+md5sums=('fc2f8fb09a4bbc0260b97e835b369184')
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}