summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bda6582d3fb9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu Mar 24 10:25:52 UTC 2016
+pkgbase = python2-stl
+ pkgdesc = Read and write STL 3D geometry files in both the ASCII and the binary flavor
+ pkgver = 0.0.3
+ pkgrel = 1
+ url = UNKNOWN
+ arch = any
+ license = MIT
+ makedepends = python2-distribute
+ depends = python2
+ source = https://pypi.python.org/packages/source/s/stl/stl-0.0.3.tar.gz
+ sha256sums = 03a6b58ad52ecf16823b1cf1acf6ef382aa5c0fc1152379f464e284a4f81304b
+
+pkgname = python2-stl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c81f731d64a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+#Automatically generated by pip2arch on 2016-03-24
+
+pkgname=python2-stl
+pkgver=0.0.3
+pkgrel=1
+pkgdesc="Read and write STL 3D geometry files in both the ASCII and the binary flavor"
+url="UNKNOWN"
+depends=('python2' )
+makedepends=('python2-distribute' )
+license=('MIT')
+arch=('any')
+source=("https://pypi.python.org/packages/source/s/stl/stl-${pkgver}.tar.gz")
+sha256sums=('03a6b58ad52ecf16823b1cf1acf6ef382aa5c0fc1152379f464e284a4f81304b')
+
+build() {
+ cd "${srcdir}/stl-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/stl-${pkgver}"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}