summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 29 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07dd4cdf6fae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python2-unqlite
+ pkgdesc = Fast Python bindings for the UnQLite embedded NoSQL database.
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = https://github.com/coleifer/unqlite-python
+ arch = any
+ license = MIT
+ makedepends = python2
+ makedepends = python2-pip
+
+pkgname = python2-unqlite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e6a33016666
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Uko Koknevics <perkontevs@gmail.com>
+# Python package author: Charles Leifer <UNKNOWN>
+pkgname=python2-unqlite
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="Fast Python bindings for the UnQLite embedded NoSQL database."
+arch=(any)
+url="https://github.com/coleifer/unqlite-python"
+license=(MIT)
+makedepends=("python2" "python2-pip")
+build() {
+ pip2 install --no-deps --target="unqlite" unqlite
+}
+package() {
+ mkdir -p $pkgdir/usr/lib/python2.7/site-packages/
+ cp -r $srcdir/unqlite/* $pkgdir/usr/lib/python2.7/site-packages/
+}