summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ddbc1065aa7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-webhelpers
+ pkgdesc = A library of helper functions to make writing templates in web applications easier
+ pkgver = 1.3
+ pkgrel = 2
+ url = http://pypi.python.org/pypi/WebHelpers/1.3
+ arch = any
+ license = BSD
+ makedepends = setuptools
+ depends = python2
+ conflicts = python-webhelpers
+ source = http://pypi.python.org/packages/source/W/WebHelpers/WebHelpers-1.3.tar.gz
+ md5sums = 32749ffadfc40fea51075a7def32588b
+
+pkgname = python2-webhelpers
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4998924e9e87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+#Maintainer: ParadoxSpiral <paradoxspiral[at]riseup[dot]net>
+#Contributor: Cilyan Olowen <gaknar@gmail.com>
+#Contributor: Nathan Jones <nathanj@insightbb.com>
+
+pkgname=python2-webhelpers
+pkgver=1.3
+pkgrel=2
+pkgdesc="A library of helper functions to make writing templates in web applications easier"
+depends=('python2')
+makedepends=('setuptools')
+conflicts=('python-webhelpers')
+source=("http://pypi.python.org/packages/source/W/WebHelpers/WebHelpers-$pkgver.tar.gz")
+url="http://pypi.python.org/pypi/WebHelpers/1.3"
+license=('BSD')
+arch=('any')
+md5sums=('32749ffadfc40fea51075a7def32588b')
+
+package() {
+ cd $srcdir/WebHelpers-$pkgver
+ python2 setup.py install --root=$pkgdir/ --optimize=1
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
+ -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ $(find $pkgdir -name '*.py')
+}