summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1b36f879438
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-xenstore
+ pkgdesc = Python XenStore Module
+ pkgver = 0.0.2
+ pkgrel = 4
+ url = https://pypi.python.org/pypi/pyxenstore
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = python2-distribute
+ depends = python2
+ depends = xenstore
+ provides = python2-pyxenstore
+ replaces = python2-pyxenstore
+ source = https://pypi.python.org/packages/source/p/pyxenstore/pyxenstore-0.0.2.tar.gz
+ md5sums = 4da2524ed0ec9439afc5c9a46ac21c6c
+
+pkgname = python2-xenstore
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73a57445c619
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 110209 2014-04-26 23:40:24Z dwallace $
+# Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
+pkgname=python2-xenstore
+pkgver=0.0.2
+pkgrel=4
+pkgdesc="Python XenStore Module"
+arch=('x86_64' 'i686')
+url="https://pypi.python.org/pypi/pyxenstore"
+license=('GPL')
+depends=('python2' 'xenstore')
+makedepends=('python2-distribute')
+replaces=('python2-pyxenstore')
+provides=('python2-pyxenstore')
+source=("https://pypi.python.org/packages/source/p/py${pkgname#*-}/py${pkgname#*-}-$pkgver.tar.gz")
+md5sums=('4da2524ed0ec9439afc5c9a46ac21c6c')
+
+build() {
+ cd "$srcdir/py${pkgname#*-}-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/py${pkgname#*-}-$pkgver"
+ python2 setup.py install --root="$pkgdir/"
+}
+
+# vim:set ts=2 sw=2 et: