summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
-rw-r--r--mpdecimal-2.5.1.patch45
4 files changed, 71 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 681425cd0e8b..65936b85e3a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = python38
pkgdesc = Major release 3.8 of the Python high-level programming language
- pkgver = 3.8.0b1
+ pkgver = 3.8.19
pkgrel = 1
url = https://www.python.org/
arch = i686
arch = x86_64
- license = custom
+ license = PSF-2.0
makedepends = tk
makedepends = sqlite
makedepends = bluez-libs
@@ -18,9 +18,12 @@ pkgbase = python38
depends = zlib
optdepends = tk: for tkinter
optdepends = sqlite
- options = !makeflags
- source = https://www.python.org/ftp/python/3.8.0/Python-3.8.0b1.tar.xz
- sha256sums = bd9f113242c95463fd95a5b2e9e48a00edcb9c2eb7f9a56cee864e4c5be37f10
+ source = https://www.python.org/ftp/python/3.8.19/Python-3.8.19.tar.xz
+ source = https://www.python.org/ftp/python/3.8.19/Python-3.8.19.tar.xz.asc
+ source = mpdecimal-2.5.1.patch
+ validpgpkeys = E3FF2839C048B25C084DEBE9B26995E310250568
+ sha256sums = d2807ac69f69b84fd46a0b93bbd02a4fa48d3e70f4b2835ff0f72a2885040076
+ sha256sums = SKIP
+ sha256sums = 8eb389be1babe03a0231001dc16dd2d69a3ea0fbf6b8c976a580787e7ff1594c
pkgname = python38
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..15d58065bc40
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.xz
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
index b573445dda01..d7b91d84c0c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,38 @@
# Maintained at https://github.com/rixx/pkgbuilds, feel free to submit patches
pkgname=python38
-pkgver=3.8.0b1
+pkgver=3.8.19
pkgrel=1
-_pyver=3.8.0
_pybasever=3.8
_pymajver=3
pkgdesc="Major release 3.8 of the Python high-level programming language"
arch=('i686' 'x86_64')
-license=('custom')
+license=('PSF-2.0')
url="https://www.python.org/"
depends=('expat' 'bzip2' 'gdbm' 'openssl' 'libffi' 'zlib')
makedepends=('tk' 'sqlite' 'bluez-libs' 'mpdecimal')
optdepends=('tk: for tkinter' 'sqlite')
-options=('!makeflags')
-source=(https://www.python.org/ftp/python/${_pyver}/Python-${pkgver}.tar.xz)
-sha256sums=('bd9f113242c95463fd95a5b2e9e48a00edcb9c2eb7f9a56cee864e4c5be37f10')
+source=(
+ https://www.python.org/ftp/python/${pkgver}/Python-${pkgver}.tar.xz
+ https://www.python.org/ftp/python/${pkgver}/Python-${pkgver}.tar.xz.asc
+ mpdecimal-2.5.1.patch
+)
+sha256sums=('d2807ac69f69b84fd46a0b93bbd02a4fa48d3e70f4b2835ff0f72a2885040076'
+ 'SKIP'
+ '8eb389be1babe03a0231001dc16dd2d69a3ea0fbf6b8c976a580787e7ff1594c')
+validpgpkeys=('E3FF2839C048B25C084DEBE9B26995E310250568')
prepare() {
cd "${srcdir}/Python-${pkgver}"
+ patch -p1 -i "${srcdir}/mpdecimal-2.5.1.patch"
+
# FS#23997
sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python|" Lib/cgi.py
# Ensure that we are using the system copy of various libraries (expat, zlib and libffi),
# rather than copies shipped in the tarball
rm -rf Modules/expat
- rm -rf Modules/zlib
rm -rf Modules/_ctypes/{darwin,libffi}*
rm -rf Modules/_decimal/libmpdec
}
@@ -58,13 +64,6 @@ package() {
rm -f "${pkgdir}/usr/lib/libpython${_pymajver}.so"
rm -f "${pkgdir}/usr/share/man/man1/python${_pymajver}.1"
- # Fix FS#22552
- ln -sf ../../libpython${_pybasever}m.so \
- "${pkgdir}/usr/lib/python${_pybasever}/config-${_pybasever}-${CARCH}-linux-gnu/libpython${_pybasever}m.so"
-
- # Fix pycairo build
- ln -sf python${_pybasever}m-config "${pkgdir}/usr/bin/python${_pybasever}-config"
-
# Clean-up reference to build directory
sed -i "s|$srcdir/Python-${pkgver}:||" "$pkgdir/usr/lib/python${_pybasever}/config-${_pybasever}-${CARCH}-linux-gnu/Makefile"
diff --git a/mpdecimal-2.5.1.patch b/mpdecimal-2.5.1.patch
new file mode 100644
index 000000000000..47e427c62a91
--- /dev/null
+++ b/mpdecimal-2.5.1.patch
@@ -0,0 +1,45 @@
+From dd436be488bdca2123d12d1e148d85cb6f98be5f Mon Sep 17 00:00:00 2001
+From: Stefan Krah <skrah@bytereef.org>
+Date: Sun, 10 Jan 2021 16:35:48 +0100
+Subject: [PATCH] Portability fixes.
+
+---
+ Modules/_decimal/_decimal.c | 4 ++--
+ setup.py | 2 +-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Modules/_decimal/_decimal.c b/Modules/_decimal/_decimal.c
+index 664d45a90481d..bbd540bc376e2 100644
+--- a/Modules/_decimal/_decimal.c
++++ b/Modules/_decimal/_decimal.c
+@@ -3295,7 +3295,7 @@ dec_format(PyObject *dec, PyObject *args)
+ }
+ else {
+ size_t n = strlen(spec.dot);
+- if (n > 1 || (n == 1 && !isascii((uchar)spec.dot[0]))) {
++ if (n > 1 || (n == 1 && !isascii((unsigned char)spec.dot[0]))) {
+ /* fix locale dependent non-ascii characters */
+ dot = dotsep_as_utf8(spec.dot);
+ if (dot == NULL) {
+@@ -3304,7 +3304,7 @@ dec_format(PyObject *dec, PyObject *args)
+ spec.dot = PyBytes_AS_STRING(dot);
+ }
+ n = strlen(spec.sep);
+- if (n > 1 || (n == 1 && !isascii((uchar)spec.sep[0]))) {
++ if (n > 1 || (n == 1 && !isascii((unsigned char)spec.sep[0]))) {
+ /* fix locale dependent non-ascii characters */
+ sep = dotsep_as_utf8(spec.sep);
+ if (sep == NULL) {
+diff --git a/setup.py b/setup.py
+index ddc0bd067d4e4..c547a68664e8c 100644
+--- a/setup.py
++++ b/setup.py
+@@ -2199,7 +2199,7 @@ def detect_decimal(self):
+ undef_macros = []
+ if '--with-system-libmpdec' in sysconfig.get_config_var("CONFIG_ARGS"):
+ include_dirs = []
+- libraries = [':libmpdec.so.2']
++ libraries = ['mpdec']
+ sources = ['_decimal/_decimal.c']
+ depends = ['_decimal/docstrings.h']
+ else: