summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO19
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
3 files changed, 73 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..db403e455696
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,19 @@
+pkgbase = pythonmagick
+ pkgdesc = Object-oriented Python bindings for the ImageMagick library
+ pkgver = 0.9.11
+ pkgrel = 2
+ url = http://www.imagemagick.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = perl
+ makedepends = automake
+ depends = boost
+ depends = python
+ depends = imagemagick
+ options = !libtool
+ source = http://www.imagemagick.org/download/python/PythonMagick-0.9.11.tar.gz
+ md5sums = 8af559d540a8e976d830ede9c79c683e
+
+pkgname = pythonmagick
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db403e455696
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pythonmagick
+ pkgdesc = Object-oriented Python bindings for the ImageMagick library
+ pkgver = 0.9.11
+ pkgrel = 2
+ url = http://www.imagemagick.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = perl
+ makedepends = automake
+ depends = boost
+ depends = python
+ depends = imagemagick
+ options = !libtool
+ source = http://www.imagemagick.org/download/python/PythonMagick-0.9.11.tar.gz
+ md5sums = 8af559d540a8e976d830ede9c79c683e
+
+pkgname = pythonmagick
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82da15656880
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Michael Schubert <mschu.dev at gmail>
+# Contributor: Florian Richter <Florian_Richter@gmx.de>
+
+pkgname=pythonmagick
+pkgver=0.9.11
+pkgrel=2
+pkgdesc="Object-oriented Python bindings for the ImageMagick library"
+arch=('i686' 'x86_64')
+url="http://www.imagemagick.org/"
+license=('custom')
+depends=('boost' 'python' 'imagemagick')
+makedepends=('perl' 'automake')
+options=('!libtool')
+source=("http://www.imagemagick.org/download/python/PythonMagick-$pkgver.tar.gz")
+md5sums=('8af559d540a8e976d830ede9c79c683e')
+
+build() {
+ cd "$srcdir/PythonMagick-$pkgver"
+ sed -i "s/-lboost_python\ /-lboost_python3\ /" Makefile.am
+ ./autogen.pl
+
+ CPPFLAGS="`python-config --includes`" \
+ PYTHON_LIB="`python-config --libs`" \
+ ./configure --prefix=/usr --with-boost-python=boost_python3
+ # --with-boost-python=boost_python3 has no effect, therefore sed above
+
+ make
+}
+
+package() {
+ cd "$srcdir/PythonMagick-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/pythonmagick/LICENSE"
+}
+