summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0eeaccb15419..060996d8fda0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
# Generated by mksrcinfo v8
-# Tue Mar 27 08:03:44 UTC 2018
+# Wed Apr 25 04:25:20 UTC 2018
pkgbase = pyutil
pkgdesc = general-purpose python library (used by tahoe-lafs)
pkgver = 3.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://pypi.python.org/pypi/pyutil
arch = any
license = GPL2
+ checkdepends = python2-twisted
+ checkdepends = python2-mock
makedepends = python2-setuptools
depends = python2
depends = python2-simplejson
depends = zbase32
- depends = python2-twisted
source = https://pypi.python.org/packages/54/16/11f89043cf7732fcc9493df558d2286c729a71efdd620dd744fdf659b4da/pyutil-3.1.0.tar.gz
md5sums = a9ad3a8c87cadc56f2880a10e0e8219d
diff --git a/PKGBUILD b/PKGBUILD
index 6002d406133b..7afb30224ce7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,14 @@
pkgname=pyutil
pkgver=3.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="general-purpose python library (used by tahoe-lafs)"
arch=('any')
url='https://pypi.python.org/pypi/pyutil'
license=('GPL2')
-depends=('python2' 'python2-simplejson' 'zbase32' 'python2-twisted')
+depends=('python2' 'python2-simplejson' 'zbase32')
makedepends=('python2-setuptools')
+checkdepends=('python2-twisted' 'python2-mock')
source=("https://pypi.python.org/packages/54/16/11f89043cf7732fcc9493df558d2286c729a71efdd620dd744fdf659b4da/pyutil-${pkgver}.tar.gz")
md5sums=('a9ad3a8c87cadc56f2880a10e0e8219d')
@@ -18,7 +19,7 @@ build(){
python2 setup.py build
}
-BUILDENV+=(!check)
+#BUILDENV+=(!check)
check() {
cd "$srcdir/pyutil-$pkgver"
python2 setup.py test