summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD69
-rw-r--r--buildconfig.arch207
-rw-r--r--buildconfig.arch.sigbin0 -> 566 bytes
-rw-r--r--q2pro.install3
-rw-r--r--r1093.tar.gz.sig16
-rw-r--r--r1504.tar.gz.sigbin0 -> 566 bytes
7 files changed, 261 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cb806e3c1a1..b61c57034eb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Apr 16 23:44:53 UTC 2017
+# Mon Jul 30 02:35:22 UTC 2018
pkgbase = q2pro
pkgdesc = An enhanced Quake 2 client and server
- pkgver = 1093
- pkgrel = 2
+ pkgver = r1504
+ pkgrel = 1
url = http://skuller.net/q2pro/
install = q2pro.install
arch = i686
@@ -15,9 +15,13 @@ pkgbase = q2pro
makedepends = openal
optdepends = quake2: additional mods (symlink to ~/.q2pro)
conflicts = q2pro-git
- source = https://github.com/AndreyNazarov/q2pro/archive/r1093.tar.gz
- source = r1093.tar.gz.sig
- sha512sums = 2cca3504681ff9a2cab6c1061245c660f1bfbfd1ec4acf91a798b697ed62b029d0cda969830d7ad282e5cbbd004b766285212e723340c5c98a31ddef0e034aa1
+ source = https://github.com/AndreyNazarov/q2pro/archive/r1504.tar.gz
+ source = buildconfig.arch
+ source = r1504.tar.gz.sig
+ source = buildconfig.arch.sig
+ sha512sums = a2b7e945dcc36cf2521546ccd97add1d565aa0a0acb8d3238e543d4713af0be95626929a62585ab48d1f50b1743ecd97d6e0cb3c1efda36048b822a2b2631e33
+ sha512sums = 7cc08a87b07d704b926d703638f6ff045ab9a86e7a9a1d8b0d384037ceafa07b84ec9faa35881737ecb2e5735436e4fe44c836f575f01f3c301fb741b4024134
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = q2pro
diff --git a/PKGBUILD b/PKGBUILD
index 14f438a4e381..8d9e31c12686 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@ validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
# News updates for packages can be followed at https://devblog.square-r00t.net
pkgname=q2pro
-pkgver=1093
-pkgrel=2
+pkgver=r1504
+pkgrel=1
pkgdesc="An enhanced Quake 2 client and server"
arch=( 'i686' 'x86_64' )
url="http://skuller.net/q2pro/"
@@ -17,13 +17,22 @@ makedepends=('libpng12' 'libjpeg6-turbo' 'curl' 'openal')
install=q2pro.install
changelog=
noextract=()
-source=("https://github.com/AndreyNazarov/q2pro/archive/r1093.tar.gz"
- "r1093.tar.gz.sig")
-sha512sums=('2cca3504681ff9a2cab6c1061245c660f1bfbfd1ec4acf91a798b697ed62b029d0cda969830d7ad282e5cbbd004b766285212e723340c5c98a31ddef0e034aa1'
- 'SKIP')
+source=("https://github.com/AndreyNazarov/q2pro/archive/${pkgver}.tar.gz"
+ "buildconfig.arch"
+ "${pkgver}.tar.gz.sig"
+ "buildconfig.arch.sig")
+sha512sums=('a2b7e945dcc36cf2521546ccd97add1d565aa0a0acb8d3238e543d4713af0be95626929a62585ab48d1f50b1743ecd97d6e0cb3c1efda36048b822a2b2631e33'
+ '7cc08a87b07d704b926d703638f6ff045ab9a86e7a9a1d8b0d384037ceafa07b84ec9faa35881737ecb2e5735436e4fe44c836f575f01f3c301fb741b4024134'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ cp "${srcdir}/buildconfig.arch" ./.config
+}
build() {
- cd "${srcdir}/${_pkgname}-r${pkgver}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
if [ ! -f VERSION ];
then
echo "${pkgver}" > VERSION
@@ -42,19 +51,20 @@ build() {
#--disable-mvd-client
#--disable-icmp
#--single-user
- ./configure --prefix=/usr \
- --enable-baseq2 \
- --enable-server \
- --enable-curl \
- --enable-jpg \
- --enable-dinput \
- --enable-openal \
- --enable-dsound \
- --enable-anticheat \
- --enable-fps \
- --bindir=/bin \
- --libdir=/lib \
- --mandir=/share/man/man6
+ # NO LONGER USES A ./CONFIGURE SCRIPT
+# ./configure --prefix=/usr \
+# --enable-baseq2 \
+# --enable-server \
+# --enable-curl \
+# --enable-jpg \
+# --enable-dinput \
+# --enable-openal \
+# --enable-dsound \
+# --enable-anticheat \
+# --enable-fps \
+# --bindir=/bin \
+# --libdir=/lib \
+# --mandir=/share/man/man6
#--enable-png \ # broken in 1093
#--datadir=/usr/share/games/q2pro \
@@ -64,14 +74,19 @@ build() {
}
package() {
- cd "${srcdir}/${_pkgname}-r${pkgver}"
- make DESTDIR="${pkgdir}/" install
- install -D -m 0644 ${srcdir}/${_pkgname}-r${pkgver}/README ${pkgdir}/usr/share/doc/${_pkgname}/README
- install -D -m 0644 ${srcdir}/${_pkgname}-r${pkgver}/INSTALL ${pkgdir}/usr/share/doc/${_pkgname}/INSTALL
- cp -a ${srcdir}/${_pkgname}-r${pkgver}/doc/* ${pkgdir}/usr/share/doc/${_pkgname}/.
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ install -d -m 0755 ${pkgdir}/usr/{bin,share/{doc,games}/${_pkgname}}
+ install -d -m 0755 ${pkgdir}/usr/share/games/${_pkgname}/baseq2
+ install -D -m 0644 ${srcdir}/${_pkgname}-${pkgver}/src/client/ui/q2pro.menu ${pkgdir}/usr/share/games/${_pkgname}/baseq2/q2pro.menu
+ install -D -m 0644 ${srcdir}/${_pkgname}-${pkgver}/README ${pkgdir}/usr/share/doc/${_pkgname}/README
+ install -D -m 0644 ${srcdir}/${_pkgname}-${pkgver}/INSTALL ${pkgdir}/usr/share/doc/${_pkgname}/INSTALL
+ cp -a ${srcdir}/${_pkgname}-${pkgver}/doc/* ${pkgdir}/usr/share/doc/${_pkgname}/.
+ cp -a ${srcdir}/${_pkgname}-${pkgver}/game*.so ${pkgdir}/usr/share/games/${_pkgname}/baseq2/.
# r1093 doesn't seem to honor manpage installation
install -d -m 0755 ${pkgdir}/usr/share/man/man6
- gzip -c ${srcdir}/${_pkgname}-r${pkgver}/man/q2pro.6.txt > ${pkgdir}/usr/share/man/man6/q2pro.6.gz
- gzip -c ${srcdir}/${_pkgname}-r${pkgver}/man/q2proded.6.txt > ${pkgdir}/usr/share/man/man6/q2proded.6.gz
+ gzip -c ${srcdir}/${_pkgname}-${pkgver}/man/q2pro.6.txt > ${pkgdir}/usr/share/man/man6/q2pro.6.gz
+ gzip -c ${srcdir}/${_pkgname}-${pkgver}/man/q2proded.6.txt > ${pkgdir}/usr/share/man/man6/q2proded.6.gz
+ install -D -m 0755 ${srcdir}/${_pkgname}-${pkgver}/q2pro ${pkgdir}/usr/bin/q2pro
+ install -D -m 0755 ${srcdir}/${_pkgname}-${pkgver}/q2proded ${pkgdir}/usr/bin/q2proded
}
diff --git a/buildconfig.arch b/buildconfig.arch
new file mode 100644
index 000000000000..cdbe5c8e6a5e
--- /dev/null
+++ b/buildconfig.arch
@@ -0,0 +1,207 @@
+# Example Q2PRO build time configuration file. Copy this file to `.config' and
+# edit it to suit your needs.
+#
+# Any variable that is commented out is DISABLED. Setting a variable to some
+# non-empty value ENABLES it. It doesn't really matter what value the variable
+# is set to, except in cases where the variable is NOT a boolean.
+#
+# After you change something in `.config', make sure to do a full rebuild by
+# typing `make clean; make'.
+
+
+### Client configuration ###
+
+# Enable PNG textures by linking against libpng.
+CONFIG_PNG=y
+
+# Enable JPEG textures by linking against libjpeg.
+CONFIG_JPEG=y
+
+# Enable HTTP downloads by linking against libcurl.
+CONFIG_HTTP=y
+
+# Enable OpenAL sound engine.
+CONFIG_OPENAL=y
+
+# Enable direct sound driver (DirectSound on Windows, OSS on Linux). This
+# option has no effect if CONFIG_NO_SOFTWARE_SOUND is set.
+CONFIG_DIRECT_SOUND=y
+
+# Enable direct mouse driver (DirectInput on Windows, evdev kernel interface on
+# Linux). Note: DirectInput is deprecated on Windows (raw input is preferred).
+CONFIG_DIRECT_INPUT=y
+
+# Enable reading input events from LIRC by linking against liblirc_client.
+# This option has no effect on Windows.
+#CONFIG_LIRC=y
+
+# Enable X11 support in SDL video driver by linking against libX11. Currently,
+# this enables GLX_SGI_video_sync extension and allows pasting text into client
+# console from the X selection buffer. This option has no effect on Windows.
+CONFIG_X11=y
+
+# Build software renderer instead of OpenGL renderer.
+#CONFIG_SOFTWARE_RENDERER=y
+
+# Specify default list of fullscreen modes. Note: modes are automatically
+# detected on Windows. Default list is only used when autodetection fails.
+#CONFIG_DEFAULT_MODELIST=640x480 800x600 1024x768
+
+# Specify default window geometry.
+#CONFIG_DEFAULT_GEOMETRY=640x480
+
+# Disable default Quake 2 software sound engine. Only makes sense when
+# CONFIG_OPENAL is set.
+CONFIG_NO_SOFTWARE_SOUND=y
+
+# Disable automatic discovery of evdev device nodes by not linking
+# against libudev. This option has no effect on platforms other than Linux.
+# This option has no effect unless CONFIG_DIRECT_INPUT is set.
+#CONFIG_NO_UDEV=y
+
+# Disable menu-based user interface. This disables scriptable menus, as well as
+# demo and server browsers.
+#CONFIG_NO_MENUS=y
+
+# Disable dynamic lighting.
+#CONFIG_NO_DYNAMIC_LIGHTS=y
+
+# Disable automatic replies to "!version" chat probes.
+#CONFIG_NO_AUTOREPLY=y
+
+# Disable MD3 models.
+#CONFIG_NO_MD3=y
+
+# Disable TGA textures.
+#CONFIG_NO_TGA=y
+
+
+### Server configuration ###
+
+# Enable r1ch.net anticheat server interface.
+CONFIG_ANTICHEAT_SERVER=y
+
+# Enable local MVD recording and MVD/GTV server functionality. Use this for
+# hosting a GTV-capable game server.
+CONFIG_MVD_SERVER=y
+
+# Enable MVD/GTV client functionality. Use this for hosting a GTV relay server.
+CONFIG_MVD_CLIENT=y
+
+
+### X86 options ###
+
+# Options below have no effect on architectures other than x86.
+
+# Enable this option on Linux to build a server capable of loading game mods
+# built using ancient GCC versions.
+CONFIG_X86_GAME_ABI_HACK=y
+
+
+### Common configuration ###
+
+# Enable this when targeting native Windows.
+#CONFIG_WINDOWS=y
+
+# Enable crash dump generation on Windows.
+#CONFIG_WINDOWS_CRASH_DUMPS=y
+
+# Allow dedicated server to be run as Windows service.
+#CONFIG_WINDOWS_SERVICE=y
+
+# Enable experimental variable server FPS support in server and client.
+#CONFIG_VARIABLE_SERVER_FPS=y
+
+# Enable built-in tests. DON'T USE IN RELEASE BUILDS.
+#CONFIG_TESTS=y
+
+# Enable debugging and developer code.
+#CONFIG_DEBUG=y
+
+# Don't link against zlib. Not recommended for client builds, since lack of
+# zlib support breaks compatibility with servers running protocol 35.
+#CONFIG_NO_ZLIB=y
+
+# Don't handle ICMP errors on UDP sockets.
+#CONFIG_NO_ICMP=y
+
+# Don't print console text on standard output and don't read commands from
+# standard input.
+#CONFIG_NO_SYSTEM_CONSOLE=y
+
+
+### Game directories ###
+
+# Name of the game directory used as base game directory. Default value is
+# "baseq2". Change this when creating a standalone game using Q2PRO engine.
+#CONFIG_GAME_BASE=baseq2
+
+# Name of the game directory used as default game directory. Default value is
+# empty. This option sets the default value of "game" console variable. Change
+# this for building a version of Q2PRO customized for particular game mod, e.g.
+# "action".
+#CONFIG_GAME_DEFAULT=
+
+
+### System paths ###
+
+# By default Q2PRO assumes per-user installation: all game content, configs and
+# executable files are kept in the same directory tree. This configuration is
+# easy for most users to set up, but not ideal from security standpoint.
+#
+# Uncomment the options below if you wish to install Q2PRO system-wide,
+# separating static, executable and writable content into different trees with
+# different permissions. These options have no effect on Windows.
+
+# Path to the game data tree. This is where all static, non-executable data
+# lives (e.g., paks). This option sets the default value of "basedir" console
+# variable. Default value of this option is "." (current directory).
+CONFIG_PATH_DATA=/usr/share/games/q2pro
+
+# Path to the game libraries tree. This is where executable parts of all game
+# mods live (e.g., game$(CPU).so files). This option sets the default value of
+# "libdir" console variable. Default value of this option is "." (current
+# directory).
+CONFIG_PATH_LIB=/usr/share/games/q2pro
+
+# Name of the directory where Q2PRO stores per-user data. Tilde at the
+# beginning of the name is automatically expanded to user home directory at run
+# time. Users running Q2PRO must have write permissions to this directory.
+# This option sets the default value of "homedir" console variable. Default
+# value of this option is "" (use basedir as homedir).
+CONFIG_PATH_HOME=~/.q2pro
+
+
+### Options for cross-compiling. ###
+
+# Force cpu type to CPU, instead of autodetecting it.
+#CPU=x86
+
+# Force system type to CPU, instead of autodetecting it.
+#SYS=Win32
+
+# Force different utility names.
+#CC=i686-w64-mingw32-gcc
+#WINDRES=i686-w64-mingw32-windres
+#STRIP=i686-w64-mingw32-strip
+#RM=rm -f
+#RMDIR=rm -rf
+#MKDIR=mkdir -p
+
+# Specify additional global include and library options.
+#INCLUDES=
+#LIBS=
+
+# Disable autodetection and force include and library options for various
+# libraries.
+#CURL_CFLAGS=
+#CURL_LIBS=
+
+#PNG_CFLAGS=
+#PNG_LIBS=
+
+#JPG_CFLAGS=
+#JPG_LIBS=
+
+#ZLIB_CFLAGS=
+#ZLIB_LIBS=
diff --git a/buildconfig.arch.sig b/buildconfig.arch.sig
new file mode 100644
index 000000000000..f1363e00775f
--- /dev/null
+++ b/buildconfig.arch.sig
Binary files differ
diff --git a/q2pro.install b/q2pro.install
index 6385b2dee5ac..7e6617dacfa2 100644
--- a/q2pro.install
+++ b/q2pro.install
@@ -1,7 +1,8 @@
post_install() {
echo "To play Quake 2, you need the following files from the disc:
copy <cdromdir>/Install/Data/baseq2/pak*.pak to /usr/share/games/q2pro2/baseq2/
-copy <cdromdir>/Install/Data/baseq2/video/ to /usr/share/games/q2pro2/baseq2/"
+copy <cdromdir>/Install/Data/baseq2/video/ to /usr/share/games/q2pro2/baseq2/
+copy <cdromdir>/Install/Data/baseq2/players/ to /usr/share/games/q2pro2/baseq2/"
## not yet implemented
#To play The Reckoning, you need the following files from the disc:
diff --git a/r1093.tar.gz.sig b/r1093.tar.gz.sig
deleted file mode 100644
index f80acec7eada..000000000000
--- a/r1093.tar.gz.sig
+++ /dev/null
@@ -1,16 +0,0 @@
------BEGIN PGP SIGNATURE-----
-
-iQIzBAABCgAdFiEEdIIx68vYCKFPXoXSjABML5NIH2sFAljz6NcACgkQjABML5NI
-H2txdA//RJOltPCzH5GqI7881M9r01XBX/S2/jlHuuBVIID0y1mCScfDi6lB75dH
-/Juv/sNd6k1zwvKVh/MWK56LWn9b6LKyl13hkskbxVUS7eLznqdceE2jkhf45hk1
-QDNqIxkfW7o82BWVTe9gMHXV5nyg1b9AZc0/Pdlp2jSTENN0cVbSzupYezbI+yd/
-5L9KkurVQdMpJk/PZmPERjgC4hw3N4lnsThgJjIsL99kpGd9DkbMTX8fgX8SaXpc
-DiEnLs6D1/sIpNjuNb08lOCJeKLkp7eQcKtxlddKgSWep11/y0HGoccX/va1yZgI
-+DLhSxq9OyzeR0DbAw8NCNk5uzuZY4sV47jIGhUv6PJyLSbqry4dPWYCW6VjPX1i
-A46R2qfUftrX7KC1wbkvgxm8SCEtJq2vEK9s/JIGwtEmMl5B/Wk8iRAQJx3ziw8S
-0QFJFSUSoGYjtESCVwdBD3xkJ0WMMHuJdXCr0oQ1MZmpmRNNy+A3O7GtsorUnznD
-seqwrU/Zm0fT9G/Xv1x7KXvLVkpNAhgl6cmPHKiCRHGK7gIoCcOzgUj+BK5OB+9J
-Ftq8IdvSOG8eL5LSuKzvrgJXisjdGuN3Cv7Az8miDwHgtwECC8gvuJH+DD70HKvl
-2NOlpb0xFERr0pTNeipg14bAdq0Bj3zVGetawNdZtyTYv8CS4d0=
-=yxu3
------END PGP SIGNATURE-----
diff --git a/r1504.tar.gz.sig b/r1504.tar.gz.sig
new file mode 100644
index 000000000000..8df4ea5d2df1
--- /dev/null
+++ b/r1504.tar.gz.sig
Binary files differ