summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD46
-rw-r--r--Q7Z.install58
3 files changed, 126 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b86382b4173c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = q7z
+ pkgdesc = An alternative 7-Zip GUI - replaced by the 'j7z' package
+ pkgver = 0.9.1
+ pkgrel = 2
+ url = http://Q7Z.Xavion.name
+ install = Q7Z.install
+ arch = any
+ license = LGPL3
+ depends = pyqt
+ depends = p7zip
+ depends = tar
+ optdepends = p7zip-gui: The GUI component of P7Zip
+ optdepends = xz-utils: Supports XZ archives
+ optdepends = bzip2: Supports BZip2 archives
+ optdepends = gzip: Supports GZip archives
+ conflicts = k7z
+ replaces = k7z
+ source = http://prdownloads.sourceforge.net/k7z/Q7Z-0.9.1.tar.bz2
+ sha1sums = d6571cd7fe5acdb7863d50dad6700feefc534276
+
+pkgname = q7z
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77e42f4146eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+
+pkgname=q7z
+_filename_=Q7Z
+pkgver=0.9.1
+pkgrel=2
+pkgdesc="An alternative 7-Zip GUI - replaced by the 'j7z' package"
+arch=("any")
+url="http://${_filename_}.Xavion.name"
+license=("LGPL3")
+depends=("pyqt" "p7zip" "tar")
+optdepends=("p7zip-gui: The GUI component of P7Zip"
+ "xz-utils: Supports XZ archives"
+ "bzip2: Supports BZip2 archives"
+ "gzip: Supports GZip archives")
+conflicts=("k7z")
+replaces=("k7z")
+install="${_filename_}.install"
+source=(http://prdownloads.sourceforge.net/k7z/${_filename_}-${pkgver}.tar.bz2)
+
+build() {
+ cd "${srcdir}"/${_filename_}/Build
+
+ # Messages
+ warning "This application was replaced by J7Z; you should use the 'j7z' package instead."
+ read -p "==> QUESTION: Do you wish to continue building this package despite its deprecated status? [y/N] " -n 1
+ if [[ ! $REPLY =~ ^[Yy]$ ]]; then
+ echo ""
+ return 1
+ fi
+
+ #make uninstall
+ #make clean
+ make
+}
+
+package() {
+ cd "${srcdir}"/${_filename_}/Build
+
+ make DESTDIR="${pkgdir}" install
+
+ # Messages
+ msg "Seek further information or send feedback via the 'Help' menu."
+}
+
+sha1sums=('d6571cd7fe5acdb7863d50dad6700feefc534276')
diff --git a/Q7Z.install b/Q7Z.install
new file mode 100644
index 000000000000..161631861a2f
--- /dev/null
+++ b/Q7Z.install
@@ -0,0 +1,58 @@
+# Q7Z: Installer: Arch
+# Contributor: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+
+post_install() {
+ # Change file permissions
+ chmod 777 /usr/share/Q7Z/Source/
+
+ # Remove old files
+ user_remove
+
+ #/bin/true
+}
+
+post_upgrade() {
+ post_install
+ #/bin/true
+}
+
+pre_remove() {
+ /bin/true
+}
+
+user_remove() {
+ # User
+ if [ ${USER} ]; then
+ export USER=${LOGNAME}
+ fi
+
+ # Home
+ if [ ${SUDO_USER} ]; then
+ export HOME=/home/${SUDO_USER}
+ else
+ export HOME=/home/${USER}
+ fi
+
+ # KDE
+ rm -f ${HOME}/.kde*/share/kde4/services/ServiceMenus/?7Z*
+ rm -f ${HOME}/.kde*/share/apps/konqueror/servicemenus/?7Z*
+
+ # Gnome
+ rm -rf ${HOME}/.gnome2/nautilus-scripts/Archiving/?7Z*
+
+ # Xfce
+ rm -f ${HOME}/.config/Thunar/uca.xml.?7Z
+}
+
+post_remove() {
+ rm -rf /usr/share/Q7Z/
+
+ user_remove
+
+ #/bin/true
+}
+
+op=$1
+shift
+
+$op "$@"