summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
-rw-r--r--qb64.install7
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02ebe517aa5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = qb64
+ pkgdesc = BASIC for the modern era
+ pkgver = 2.0.2
+ pkgrel = 1
+ url = https://www.qb64.org/
+ install = qb64.install
+ arch = x86_64
+ license = custom
+ makedepends = gcc
+ makedepends = zlib
+ makedepends = xorg-xmessage
+ options = !strip
+ source = https://github.com/QB64Team/qb64/archive/refs/tags/v2.0.2.tar.gz
+ sha256sums = ba4ce7a7a7574ff065707f85c8d5cb741063eae7f7b7e55eb79f9037f300e991
+
+pkgname = qb64
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..586ff0eeb53e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Alex Henrie <alexhenrie24@gmail.com>
+pkgname=qb64
+pkgver=2.0.2
+pkgrel=1
+pkgdesc='BASIC for the modern era'
+arch=('x86_64')
+url='https://www.qb64.org/'
+license=('custom')
+makedepends=('gcc' 'zlib' 'xorg-xmessage')
+options=('!strip')
+install=qb64.install
+source=("https://github.com/QB64Team/qb64/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('ba4ce7a7a7574ff065707f85c8d5cb741063eae7f7b7e55eb79f9037f300e991')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ sed -i 's!~/.local/share/applications/!!' setup_lnx.sh
+ sed -i 's!$_pwd!/opt/qb64!' setup_lnx.sh
+ sed -i 's! ./qb64 &! #./qb64 &!' setup_lnx.sh
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./setup_lnx.sh
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ mkdir -p "$pkgdir/opt/qb64"
+ cp -r internal licenses COPYING.txt qb64 qb64.1 run_qb64.sh "$pkgdir/opt/qb64"
+ chmod -R g+w "$pkgdir/opt/qb64/internal"
+ install -Dm644 qb64.desktop "$pkgdir/usr/share/applications/qb64.desktop"
+ install -Dm644 COPYING.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/qb64.install b/qb64.install
new file mode 100644
index 000000000000..97c4a6e5e1d1
--- /dev/null
+++ b/qb64.install
@@ -0,0 +1,7 @@
+post_install() {
+ getent group qb64 &> /dev/null || groupadd qb64
+ chgrp -R qb64 /opt/qb64/internal
+ echo 'To use qb64, you must be a member of the qb64 group.'
+ echo "Run \`usermod $(logname) -a -G qb64`` to add your user to the group,"
+ echo 'then log out and log back in.'
+}