summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
-rw-r--r--qbittorrent-vuetorrent.install6
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dfdd66c8243b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = qbittorrent-vuetorrent-bin
+ pkgdesc = A modern looking WebUI for qBittorrent, made with VueJS and ExpressJS
+ pkgver = 0.4.6
+ pkgrel = 1
+ url = https://github.com/WDaan/VueTorrent
+ install = qbittorrent-vuetorrent.install
+ arch = any
+ license = GPL3
+ optdepends = qbittorrent: for use with qbittorrent
+ optdepends = qbittorrent-nox: for use with qbittorrent-nox
+ source = https://github.com/WDaan/VueTorrent/releases/download/0.4.6/release.zip
+ source = qbittorrent-vuetorrent.install
+ md5sums = 5aa51091616bd3a11795b35d96bdbcf5
+ md5sums = 96ce85f1cb499e33f788bd9726873231
+
+pkgname = qbittorrent-vuetorrent-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c339fc9c006
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Falk Höppner <falk hoppner se>
+
+pkgname=qbittorrent-vuetorrent-bin
+pkgver=0.4.6
+pkgrel=1
+pkgdesc='A modern looking WebUI for qBittorrent, made with VueJS and ExpressJS'
+arch=(any)
+url='https://github.com/WDaan/VueTorrent'
+license=(GPL3)
+optdepends=(
+ 'qbittorrent: for use with qbittorrent'
+ 'qbittorrent-nox: for use with qbittorrent-nox'
+)
+install=qbittorrent-vuetorrent.install
+source=(
+ "https://github.com/WDaan/VueTorrent/releases/download/$pkgver/release.zip"
+ qbittorrent-vuetorrent.install)
+md5sums=('5aa51091616bd3a11795b35d96bdbcf5'
+ '96ce85f1cb499e33f788bd9726873231')
+
+package() {
+ cd "$srcdir/vuetorrent"
+ find . -type f -exec install -D '{}' "$pkgdir/usr/share/$pkgname/{}" ';'
+}
diff --git a/qbittorrent-vuetorrent.install b/qbittorrent-vuetorrent.install
new file mode 100644
index 000000000000..8753b5af78e3
--- /dev/null
+++ b/qbittorrent-vuetorrent.install
@@ -0,0 +1,6 @@
+post_install() {
+ cat << EOF
+>>> Make sure to enable 'Use alternative Web UI' in qBittorrent under Preferences->Web UI.
+>>> Set 'File location' to /usr/share/qbittorrent-vuetorrent.
+EOF
+}