summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c9ee2ef58e3f..7756146fb93d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,27 @@
set -e
-_pi_ver=2
+_qmake="qmake"
+_piver=""
+
+if [[ -z $_piver ]] && [[ -n $LOCAL_PI_VER ]]; then
+ _piver=$LOCAL_PI_VER
+fi
+
+if [[ -n "$_piver" ]]; then
+ _qmake="/opt/qt-sdk-raspberry-pi${_piver}/bin/qmake"
+fi
+
pkgname="qcec"
pkgver=0.0.2
-pkgrel=1
+pkgrel=2
provides=("$pkgname")
conflicts=("$pkgname")
pkgdesc="Qt CEC keyboard plugin for the Raspberry Pi"
arch=("any")
url="http://www.github.com/sirspudd/qcec"
license=("GPL3")
-makedepends=("qt-sdk-raspberry-pi${_pi_ver}")
+makedepends=("qt-sdk-raspberry-pi${_piver}")
depends=("qt-sdk-raspberry-pi-target-libs")
source=("git://github.com/sirspudd/${pkgname}.git")
sha256sums=("SKIP")
@@ -20,7 +30,6 @@ options=('!strip')
build() {
local repo_src=${srcdir}/${pkgname}
- local qmake=/opt/qt-sdk-raspberry-pi${_pi_ver}/bin/qmake
# cmake gets thrown by env vars
unset LDFLAGS
@@ -28,13 +37,13 @@ build() {
unset CXXFLAGS
cd ${repo_src}
- $qmake
+ $_qmake
make
}
package() {
local repo_src=${srcdir}/${pkgname}
- local deploy_path=${pkgdir}/opt/qt-sdk-raspberry-pi${_pi_ver}/plugins/generic
+ local deploy_path=${pkgdir}/opt/qt-sdk-raspberry-pi${_piver}/plugins/generic
local ceclib_deploy_path=${pkgdir}/usr/lib
local pkgprofiled="${pkgdir}/etc/profile.d"